Bug 41535 - UIViewControllerBasedStatusBarAppearance is set to false.
Summary: UIViewControllerBasedStatusBarAppearance is set to false.
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- minor
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-06-06 20:35 UTC by Peter Steinberger
Modified: 2016-11-16 10:06 UTC (History)
5 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Peter Steinberger 2016-06-06 20:35:43 UTC
`UIViewControllerBasedStatusBarAppearance` is set to false. This is the old, deprecated behaviour from iOS 6 and is discouraged.

This is a problem for us. We offer an SDK for PDF viewing/editing called PSPDFKit. Getting the status bar right on iOS is tricky and we can't reasonable support both modes - so we chose the default, non-deprecated mode that exists since iOS 7.

Furthermore, the old APIs for controlling the status bar are all deprecated and unavailable when building extensions.

Here's Apple's documentation on it:
https://developer.apple.com/library/mac/documentation/General/Reference/InfoPlistKeyReference/Articles/iPhoneOSKeys.html#//apple_ref/doc/uid/TP40009252-SW29

Here's our FAQ entry:
https://pspdfkit.com/guides/ios/current/faq/uiviewcontrollerbasedstatusbarappearance/

Example where this is set to false inside Xamarin's samples:
https://github.com/xamarin/Xamarin.Forms/blob/2d9288eee6e6f197364a64308183725e7bd561f9/Xamarin.Forms.ControlGallery.iOS/Info.plist#L32

I hope that the status bar management can be updated to the modern APIs so our product will work with Xamarin.Forms. I know that this can be tricky but it's definitely a step up from the previous global-state behaviour. Let me know if you have any more issues. peter@pspdfkit.com here / @steipete on Twitter. I'm at WWDC next week so I can relay questions as well.
Comment 1 adrianknight89 2016-11-06 08:00:04 UTC
I think this fixes your issue: https://github.com/xamarin/Xamarin.Forms/pull/463
Comment 2 Peter Steinberger 2016-11-06 11:44:44 UTC
Looking good - thanks!
Comment 3 Rui Marinho 2016-11-16 10:06:15 UTC
Should be fixed in 2.3.4-pre1