Bug 41530 - [iOS]TimerTest failing randomly on devices,
Summary: [iOS]TimerTest failing randomly on devices,
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: BCL Class Libraries (show other bugs)
Version: XI 9.8 (tvOS / C7)
Hardware: PC Mac OS
: Normal normal
Target Milestone: C7SR1
Assignee: Alexander Köplinger [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-06-06 15:05 UTC by GouriKumari
Modified: 2016-07-05 20:08 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description GouriKumari 2016-06-06 15:05:39 UTC

    
Comment 1 GouriKumari 2016-06-06 15:18:53 UTC
## Steps to reproduce:

Install Xamarin.iOS Cycle7 build mtouch 9.8.0.323 (cycle7: 39ebb77).
Execute System unified tests on 32  bit devices


## Actual Behaviour: 
[FAIL] TimerTest.EnabledInElapsed :   #1 loss of events
  Expected: True
  But was:  False

## Supplemental Info:
This issue is seen in iPad2 devices.

## Logs:
Test Log: 
https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=15191956
https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=15187237

## Build Log: 
https://gist.github.com/GouriKumari/f047cf95ce4355bfde58dec3dc304b10
https://gist.github.com/GouriKumari/e428f07274326dcbeb70382e40ca0286

##Test Env:
mtouch 9.8.0.323 (cycle7: 39ebb77).
This is a random failure observed only on 32 bit device. Both were on IPv6 network.
Comment 2 GouriKumari 2016-06-06 16:38:10 UTC
Changing the milestone to Cycle7SR1, since the test passed in Cycle6 and is randomly failing in Cycle7. 

Both iPads are iPad2, model number: A1395, dual core.
Comment 3 Alexander Köplinger [MSFT] 2016-06-08 11:02:37 UTC
Fixed in master/4.5.1 by https://github.com/mono/mono/pull/3122.

Trello card for getting this into C7SR1: https://trello.com/c/h3Q3i4A8/7-xi-mono-fix-flaky-timertest-enabledinelapsed
Comment 4 GouriKumari 2016-06-30 21:35:56 UTC
Verified with Xamarin.iOS master build  Xamarin.iOSVersion: 9.9.2.132 (Xamarin Business) Hash: 81a8e7a, locally on device.

Test did pass on device. Will verify once this change is added to C7 trunk.

## Logs:
Test Log: https://gist.github.com/GouriKumari/e36fc53f7acb3a7e0b646b9c8f62ed16
Build Log: https://gist.github.com/GouriKumari/d5d29e43aee0bd92b6757aa6649f1ef3
Test Env: https://gist.github.com/GouriKumari/0009baa8ee1130dae1849458dbbc352e
Comment 5 GouriKumari 2016-07-05 20:08:34 UTC
Verified with Cycle7 build  mtouch 9.8.2.11 (cycle7: 9ae33ac) and timer test did pass on the device.

## Logs:
Test Log: https://gist.github.com/GouriKumari/92dd00f03e0577e8676b0d2ce28930b3
Build Log: https://gist.github.com/GouriKumari/871c79a145df7818509b5162544e3104
Test Env: https://gist.github.com/GouriKumari/c6adbcdbf01bc34cd329fbbb0fc00cc3

##Devices:
iPad2 6.0.1