Bug 41427 - Time Profiler returns always 0ms
Summary: Time Profiler returns always 0ms
Status: RESOLVED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: iOS (show other bugs)
Version: 0.33.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: (C8)
Assignee: Rodrigo Moya
URL:
: 41337 45690 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-01 09:54 UTC by matteo
Modified: 2016-11-02 06:52 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Xamarin Profiler Log (15.99 KB, text/plain)
2016-06-03 15:07 UTC, matteo
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description matteo 2016-06-01 09:54:21 UTC

    
Comment 1 Rodrigo Moya 2016-06-03 14:42:00 UTC
Thanks you for the bug report, but can you please provide us with more information?

* What app is it?
* can you please attach the profiler logs (Help->Open log directory)
* if on Android, please attach also the contents of the 'Console' tab in the Profiler
* if on iOS, the device/simulator logs
Comment 2 matteo 2016-06-03 15:07:15 UTC
Created attachment 16187 [details]
Xamarin Profiler Log
Comment 3 Rodrigo Moya 2016-06-03 15:21:47 UTC
Ok thanks! We have a fix already for the crash in the logs you attached, which is included in the builds we are testing for releasing as soon as it passes QA, so closing this. When you get the new release, please let us if it fixes the problem for you or not.
Comment 4 asimk 2016-10-04 14:39:13 UTC
I am still getting this issue with Android application.

Screencast: http://www.screencast.com/t/i87XLBEX2H4
Device Log: https://gist.github.com/Asimk360/e4e74d0e22e6be0a18c7f659a14a0609
Ide Log: https://gist.github.com/Asimk360/e130d74e4c7402bb83fc68cb28357a6a

Environment Info:
Profiler version v0.35.99-303
https://gist.github.com/Asimk360/507586e0d1779fc8863dd515d304cf96
Comment 5 Rodrigo Moya 2016-10-04 14:55:37 UTC
What's the sample cycle frequency you have setup (in the app's Preferences dialog)?
Comment 6 asimk 2016-10-20 17:12:21 UTC
@Rodrigo, As discussed Sample cycle frequency is set to 1000.
And after changing it to 100 still getting 0ms in Running time.
Screencast: http://www.screencast.com/t/V8pX6pXpcA
Comment 7 Rodrigo Moya 2016-10-26 15:27:03 UTC
*** Bug 41337 has been marked as a duplicate of this bug. ***
Comment 8 Rolf Bjarne Kvinge [MSFT] 2016-10-27 08:40:12 UTC
*** Bug 45690 has been marked as a duplicate of this bug. ***
Comment 9 Rolf Bjarne Kvinge [MSFT] 2016-10-27 08:41:19 UTC
I can reproduce the same thing in a Xamarin.Mac app, with Sampling Frequency set to 1 or 10 (but it works with 100). (Call depth = 8 and Max frames = 8).
Comment 10 Rolf Bjarne Kvinge [MSFT] 2016-10-27 08:42:39 UTC
Version: 0.38.1-32.
Comment 11 Rodrigo Moya 2016-10-28 12:17:55 UTC
Indeed, setting sample cycle frequency to 1 or 10 gets no samples at all (for an empty Xamarin.Mac app from the template in XS).
Comment 12 xamarin-release-manager 2016-11-02 06:52:54 UTC
Fixed in version 99.0.0.158 (master)

Author: Rodrigo Moya
Commit: 9a89bc666eb2211d33651033ed993fb4c2835ba1 (xamarin/profiler)