Bug 41320 - Run Unit Tests from Run Menu isn't working. Shows NRE in log
Summary: Run Unit Tests from Run Menu isn't working. Shows NRE in log
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit (show other bugs)
Version: 6.0.0 (C7)
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Marius Ungureanu
URL:
: 41369 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-25 19:41 UTC by Manish Sinha
Modified: 2016-06-22 16:38 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Manish Sinha 2016-05-25 19:41:53 UTC
Steps to reproduce:

1. Create a test fixture
2. Create some individual tests
3. Compile the project
4. Click on Menu > Run > Run Unit Tests

Expected: The unit tests in the project should run
Actual: The project compiles and fails to run

Other examples to try: https://github.com/xamarin/QualityAssurance/blob/master/Manual/NunitTests/NunitTests.sln

From Ide.log:

INFO [2016-05-25 15:29:45Z]: Add-in loaded: MonoDevelop.HexEditor
INFO [2016-05-25 15:30:30Z]: Add-in loaded: MonoDevelop.Debugger.Soft.AspNet
The application was terminated by a signal: SIGKILL
ERROR [2016-05-25 15:30:58Z]: An unhandled exception has occured. Terminating Xamarin Studio? False
System.NullReferenceException: Object reference not set to an instance of an object
  at MonoDevelop.UnitTesting.TestSession..ctor (MonoDevelop.UnitTesting.UnitTest test, MonoDevelop.Projects.ExecutionContext context, MonoDevelop.UnitTesting.TestResultsPad resultsPad, System.Threading.CancellationTokenSource cs) [0x00006] in /Users/builder/data/lanes/2920/67f841c7/source/monodevelop/main/src/addins/MonoDevelop.UnitTesting/Services/UnitTestService.cs:404 
  at MonoDevelop.UnitTesting.UnitTestService+<RunTest>c__async0.MoveNext () [0x002c4] in /Users/builder/data/lanes/2920/67f841c7/source/monodevelop/main/src/addins/MonoDevelop.UnitTesting/Services/UnitTestService.cs:152 
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in /private/tmp/source-mono-4.4.0/bockbuild-mono-4.4.0-branch/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/mscorlib/system/runtime/exceptionservices/exceptionservicescommon.cs:143 
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x00047] in /private/tmp/source-mono-4.4.0/bockbuild-mono-4.4.0-branch/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:187 
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in /private/tmp/source-mono-4.4.0/bockbuild-mono-4.4.0-branch/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:156 
  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in /private/tmp/source-mono-4.4.0/bockbuild-mono-4.4.0-branch/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:128 
  at System.Runtime.CompilerServices.TaskAwaiter.GetResult () [0x00000] in /private/tmp/source-mono-4.4.0/bockbuild-mono-4.4.0-branch/profiles/mono-mac-xamarin/build-root/mono-x86/external/referencesource/mscorlib/system/runtime/compilerservices/TaskAwaiter.cs:113 
  at MonoDevelop.UnitTesting.UnitTestService+<RunTest>c__async0.MoveNext () [0x001d7] in /Users/builder/data/lanes/2920/67f841c7/source/monodevelop/main/src/addins/MonoDevelop.UnitTesting/Services/UnitTestService.cs:133 



XS Info:

=== Xamarin Studio Business ===

Version 6.0 (build 5169)
Installation UUID: 7c2f38ff-d195-484c-a397-3e6a0c62afa2
Runtime:
	Mono 4.4.0 (mono-4.4.0-branch/cfe7d24) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404000180

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.3 (10183.3)
Build 7D175

=== Xamarin.iOS ===

Version: 9.8.0.319 (Xamarin Business)
Hash: 7b89851
Branch: cycle7
Build date: 2016-05-20 16:56:02-0400

=== Xamarin.Android ===

Version: 6.1.0.71 (Xamarin Business)
Android SDK: /Users/manish/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Not Installed

=== Xamarin.Mac ===

Version: 2.8.0.319 (Xamarin Business)

=== Build Information ===

Release ID: 600005169
Git revision: 67f841c74eb2f367c32bc63ae1dc5e12a58ce5c4
Build date: 2016-05-24 14:12:24-04
Xamarin addins: c7761d054f38e9a210822aba6356398af0c36fa9
Build lane: monodevelop-lion-cycle7

=== Operating System ===

Mac OS X 10.11.4
Darwin cassini.local 15.4.0 Darwin Kernel Version 15.4.0
    Fri Feb 26 22:08:05 PST 2016
    root:xnu-3248.40.184~3/RELEASE_X86_64 x86_64
Comment 1 xamarin-release-manager 2016-05-31 20:46:02 UTC
Fixed in version 6.1.0.4380 (master)

Author: Marius Ungureanu
Commit: 0fcc7a078c1c3757c7039d9a1b1ed80d240f5ec6 (mono/monodevelop)
Comment 2 Lluis Sanchez 2016-06-10 07:59:10 UTC
*** Bug 41369 has been marked as a duplicate of this bug. ***
Comment 3 xamarin-release-manager 2016-06-10 08:05:07 UTC
Fixed in version 6.0.1.32 (cycle7)

Author: Marius Ungureanu
Commit: 46033b50b80519510632045e479d3c28c3623856 (mono/monodevelop)
Comment 4 xamarin-release-manager 2016-06-15 18:45:55 UTC
Fixed in version 6.0.2.19 (cycle7-app-insights-rebased)

Author: Marius Ungureanu
Commit: 46033b50b80519510632045e479d3c28c3623856 (mono/monodevelop)
Comment 5 Manish Sinha 2016-06-22 16:38:27 UTC
Verified for Cycle 7

https://gist.github.com/manish-sinha/e30d92044f2675bf5de686428e8834ae

Note You need to log in before you can comment on or make changes to this bug.