Bug 41207 - WebException occurring after most recent Xamarin.iOS update
Summary: WebException occurring after most recent Xamarin.iOS update
Status: RESOLVED DUPLICATE of bug 41653
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.1.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-05-20 09:59 UTC by martink
Modified: 2016-06-13 16:13 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
WebException (11.05 KB, text/plain)
2016-05-20 09:59 UTC, martink
Details
WebException (11.80 KB, text/plain)
2016-06-10 07:57 UTC, martink
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 41653

Description martink 2016-05-20 09:59:34 UTC
Created attachment 16048 [details]
WebException

Existing Xamarin Forms app that uses Parse as back-end (busy with migration to new back-end).

Using Xamarin Studio 6 Beta Channel. After update on Wednesday, am getting WebException with message [TlsException: Unknown Secure Transport error `ClosedGraceful'.] when calling ParseFile.SaveAsync() (full exception attached).

NOTE: this error has _never_ occurred before, the code where it occurs hasn't been touched in a long time, and only started occurring after the most recent update in the Beta channel (I believe it was the Beta RC2 release of 18/05/2016).

Rebuilding with an older version of XS, the error doesn't occur.

XS details:

=== Xamarin Studio Business ===

Version 6.0 (build 5156)
Installation UUID: afeaddc5-3486-4773-9877-a4d9f13a014c
Runtime:
	Mono 4.4.0 (mono-4.4.0-branch/0f5fdf2) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404000168

=== Xamarin.Profiler ===

Version: 0.24.0.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 7.3 (10183.3)
Build 7D175

=== Xamarin.iOS ===

Version: 9.8.0.318 (Xamarin Business)
Hash: efefc1e
Branch: cycle7
Build date: 2016-05-13 17:19:05-0400

=== Xamarin.Android ===

Version: 6.1.0.56 (Xamarin Business)
Android SDK: /Users/martin/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 600005156
Git revision: 6bb41168165682b4ed22a94364bf0cf24e6b1d5c
Build date: 2016-05-13 16:06:44-04
Xamarin addins: 32a8312bbbe9be707b6535e19c0ed3c4e4f27443
Build lane: monodevelop-lion-cycle7

=== Operating System ===

Mac OS X 10.11.5
Darwin Martins-MacBook-Pro.local 15.5.0 Darwin Kernel Version 15.5.0
    Tue Apr 19 18:36:36 PDT 2016
    root:xnu-3248.50.21~8/RELEASE_X86_64 x86_64
Comment 1 martink 2016-06-10 07:47:58 UTC
This now occurs in the latest Stable Xamarin Studio:

Xamarin Studio Business
Version 6.0 (build 5174)
Installation UUID: afeaddc5-3486-4773-9877-a4d9f13a014c
Runtime:
	Mono 4.4.0 (mono-4.4.0-branch-c7-baseline/5995f74) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404000182

Xamarin.Profiler
Version: 0.24.0.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

Apple Developer Tools
Xcode 7.3.1 (10188.1)
Build 7D1014

Xamarin.iOS
Version: 9.8.0.323 (Xamarin Business)
Hash: 39ebb77
Branch: cycle7
Build date: 2016-06-01 21:23:15-0400

Xamarin.Android
Version: 6.1.0.71 (Xamarin Business)
Android SDK: /Users/martin/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

Xamarin Android Player
Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

Xamarin.Mac
Not Installed

Build Information
Release ID: 600005174
Git revision: 694a75f040b7f2309bc43d4f78a3a6572ca898bf
Build date: 2016-06-01 17:28:08-04
Xamarin addins: 33f406fa2dcf214012c78cb846585f062b2e1d24
Build lane: monodevelop-lion-cycle7-baseline

Operating System
Mac OS X 10.11.5
Darwin Martins-MacBook-Pro.local 15.5.0 Darwin Kernel Version 15.5.0
    Tue Apr 19 18:36:36 PDT 2016
    root:xnu-3248.50.21~8/RELEASE_X86_64 x86_64
Comment 2 martink 2016-06-10 07:57:13 UTC
Created attachment 16265 [details]
WebException
Comment 3 martink 2016-06-10 07:58:10 UTC
Please note that this error is blocking us from being able to release a new version of the app
Comment 4 Erlend Figenschau Lund 2016-06-10 08:12:39 UTC
I have registered a duplicate bug report - https://bugzilla.xamarin.com/show_bug.cgi?id=41653

I first downgraded to Xamarin.iOS 9.6.2 from 16th of May 2016 with no effect (https://store.xamarin.com/account/my/subscription/downloads)

I then downgraded Mono to 4.4.2 as it was the last version where the code worked.

This downgrade solved the problem and should be a workaround for you to.

For the Mono downgrade I downloaded "MonoFramework-MDK-4.2.4.4.macos10.xamarin.x86.pkg" from http://download.mono-project.com/archive/4.2.4/macos-10-x86/ and ran the installer.

Check mono version from a terminal console:
mono --version

Prior to the downgrade, my mono was 4.4.0. After downgrade my mono version is 4.2.4.
Comment 5 martink 2016-06-13 09:14:35 UTC
Thanks for that! Can confirm, have to downgrade to both Xamarin.iOS 9.6.2 and Mono 4.4.2. In addition, had to downgrade to Xamarin Studio 5.10.3 since Mono 4.2.4 isn't compatible with XS 6.

How did XS 6 make it into stable with these two open bugs?
Comment 6 Erlend Figenschau Lund 2016-06-13 12:47:32 UTC
To run with XS 6.0 I had to install Mono 4.3.2 - http://download.mono-project.com/archive/4.3.2/macos-10-universal/

I still have the downgrade version of Xamarin.iOS 9.6.2, but it is not known if this is necessary.
Comment 7 Paul DiPietro [MSFT] 2016-06-13 16:13:05 UTC

*** This bug has been marked as a duplicate of bug 41653 ***