Bug 41137 - [Profiler - Mac] Unable to start profiling on iOS Device.
Summary: [Profiler - Mac] Unable to start profiling on iOS Device.
Status: VERIFIED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: iOS (show other bugs)
Version: 0.33.x
Hardware: PC Mac OS
: High major
Target Milestone: (C8)
Assignee: Rodrigo Moya
URL:
Depends on:
Blocks:
 
Reported: 2016-05-17 18:37 UTC by asimk
Modified: 2016-06-13 18:25 UTC (History)
4 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Comment 1 Rodrigo Moya 2016-06-03 13:42:05 UTC
Can you please provide the device logs also?
Comment 2 asimk 2016-06-08 16:46:29 UTC
@Rodrigo, Here is the device log: https://gist.github.com/Asimk360/82d19c7d5d3d781524b7452b3b8a3bab
Comment 3 mitchell balsam 2016-06-09 09:28:05 UTC
The profiler does not work on IOS.  

Create new project
Select Debug > iPhoneSimulator 
Run > Start Profiling
Profiler application starts
Start Button Greyed out. 
Nothing happens.

Sometimes i get this dialog at startup

could not open /var/folders/94/qfz_5g0j73q8dd5st_y6m1lm0000gq/T/tmp5d532025.tmp

This has been this way for months..  

Profiler is totally useless since it cant be started..
Comment 4 Rodrigo Moya 2016-06-09 12:41:10 UTC
@Asim, from that log, it is starting the debugger, not the profiler:

https://gist.github.com/Asimk360/82d19c7d5d3d781524b7452b3b8a3bab#file-devicelog-L73

In the IDE/Profiler logs all look ok, it's just waiting for the data to come, which never happens, so it looks like it can't reach indeed the iOS device.

What about simulators? it works there, right?

@Mitchell please attach the profiler/device logs, and we'll have a look.
Comment 5 asimk 2016-06-09 13:19:08 UTC
@Rodrigo, Profiling is working fine with simulator, here is the screencast:

Screencast with Simulator: http://www.screencast.com/t/gpmjEOLc
Screencast with Device: http://www.screencast.com/t/LlmCoZ5Ac
Comment 6 xamarin-release-manager 2016-06-09 13:22:56 UTC
Fixed in version 0.33.2.2 (master)

Author: Rodrigo Moya
Commit: d46238924c95edc8633dd05944f394dcfa6f05b0 (xamarin/profiler)
Comment 7 mitchell balsam 2016-06-09 16:10:35 UTC
After watching the screen cast we realized that even with the latest Xamarin Studio, the profiler was still a very old version. Had to delete profiler from machine and download it again, and double check that version 0.33.2 was specified.. 

Not sure if the fact that profiler did not update is a bug, but we at least can see the expected functions for the profiler.
Comment 8 asimk 2016-06-13 18:25:13 UTC
This issue does not exist with latest profiler build i.e. 0.33.2.79. Here is the screencast for the same: http://www.screencast.com/t/Db3rvlTRU0Js

Note You need to log in before you can comment on or make changes to this bug.