Bug 40963 - iOS app crashes when taking snapshots
Summary: iOS app crashes when taking snapshots
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Mono runtime / AOT compiler (show other bugs)
Version: XI 9.10 (C8)
Hardware: PC Mac OS
: Highest critical
Target Milestone: 10.0.0 (C8)
Assignee: Alex Rønne Petersen
URL:
: 41106 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-09 11:38 UTC by Rodrigo Moya
Modified: 2016-09-05 07:03 UTC (History)
10 users (show)

Tags: C8Beta1
Is this bug a regression?: Yes
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Rodrigo Moya 2016-05-09 11:38:21 UTC
After updating to alpha channel (C8), can no longer take snapshots on iOS, all apps I've tried crash when doing so:

May  9 13:29:30 cogulla AcquaintXFormsiOS[2092]: Error loading /System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib:  dlopen(/System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib, 262): no suitable image found.  Did find:
		/System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib: mach-o, but not built for iOS simulator
May  9 13:29:30 cogulla AcquaintXFormsiOS[2092]: Cannot find function pointer IOHIDLibFactory for factory 13AA9C44-6F1B-11D4-907C-0005028F18D5 in CFBundle/CFPlugIn 0x79e01b10 </System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin> (bundle, not loaded)
May  9 13:29:30 cogulla AcquaintXFormsiOS[2092]: Error loading /System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib:  dlopen(/System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib, 262): no suitable image found.  Did find:
		/System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib: mach-o, but not built for iOS simulator
May  9 13:29:30 cogulla AcquaintXFormsiOS[2092]: Cannot find function pointer IOHIDLibFactory for factory 13AA9C44-6F1B-11D4-907C-0005028F18D5 in CFBundle/CFPlugIn 0x79e01b10 </System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin> (bundle, not loaded)
May  9 13:29:30 cogulla AcquaintXFormsiOS[2092]: Error loading /System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib:  dlopen(/System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib, 262): no suitable image found.  Did find:
		/System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib: mach-o, but not built for iOS simulator
May  9 13:29:30 cogulla AcquaintXFormsiOS[2092]: Cannot find function pointer IOHIDLibFactory for factory 13AA9C44-6F1B-11D4-907C-0005028F18D5 in CFBundle/CFPlugIn 0x79e01b10 </System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin> (bundle, not loaded)
May  9 13:29:30 cogulla assertiond[2044]: assertion failed: 15E65 13E230: assertiond + 15801 [3C808658-78EC-3950-A264-79A64E0E463B]: 0x1
May  9 13:29:30 --- last message repeated 3 times ---
May  9 13:29:30 cogulla AcquaintXFormsiOS[2092]: Style Iddisclosure
May  9 13:29:32 --- last message repeated 7 times ---
May  9 13:29:32 cogulla assertiond[2044]: assertion failed: 15E65 13E230: assertiond + 15801 [3C808658-78EC-3950-A264-79A64E0E463B]: 0x1
May  9 13:29:32 cogulla AcquaintXFormsiOS[2092]: Style Iddisclosure
May  9 13:29:34 cogulla assertiond[2044]: assertion failed: 15E65 13E230: assertiond + 15801 [3C808658-78EC-3950-A264-79A64E0E463B]: 0x1
May  9 13:29:37 --- last message repeated 1 time ---
May  9 13:29:37 cogulla SpringBoard[2040]: Weekly asset update check did fire (force=NO)
May  9 13:29:37 cogulla SpringBoard[2040]: Beginning check for asset updates (force: 0
May  9 13:29:37 cogulla SpringBoard[2040]: Did not complete check for asset updates (force: 0, isVoiceOverRunning: 0
May  9 13:29:41 cogulla assertiond[2044]: assertion failed: 15E65 13E230: assertiond + 15801 [3C808658-78EC-3950-A264-79A64E0E463B]: 0x1
May  9 13:29:43 --- last message repeated 5 times ---
May  9 13:29:43 cogulla backboardd[2041]: CoreAnimation: updates deferred for too long
May  9 13:29:44 cogulla assertiond[2044]: assertion failed: 15E65 13E230: assertiond + 15801 [3C808658-78EC-3950-A264-79A64E0E463B]: 0x1
May  9 13:29:51 --- last message repeated 5 times ---
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 
	Native stacktrace:
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	0   AcquaintXFormsiOS                   0x0016d96d mono_handle_native_sigsegv + 317
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	1   AcquaintXFormsiOS                   0x0017b126 mono_sigsegv_signal_handler + 214
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	2   libsystem_platform.dylib            0x0978879b _sigtramp + 43
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	3   ???                                 0xffffffff 0x0 + 4294967295
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	4   AcquaintXFormsiOS                   0x001e243e mono_object_register_finalizer + 46
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	5   AcquaintXFormsiOS                   0x00247475 mono_object_new_mature + 117
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	6   AcquaintXFormsiOS                   0x0028ed88 create_internal_thread + 72
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	7   AcquaintXFormsiOS                   0x0028f306 mono_thread_attach_full + 118
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	8   AcquaintXFormsiOS                   0x0028f272 mono_thread_attach + 34
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	9   AcquaintXFormsiOS                   0x00012ab7 helper_thread + 1031
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	10  libsystem_pthread.dylib             0x09775780 _pthread_body + 138
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	11  libsystem_pthread.dylib             0x097756f6 _pthread_body + 0
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 	12  libsystem_pthread.dylib             0x09772f7a thread_start + 34
May  9 13:29:51 cogulla AcquaintXFormsiOS[2092]: critical: 
	=================================================================
	Got a SIGSEGV while executing native code. This usually indicates
	a fatal error in the mono runtime or one of the native libraries 
	used by your application.
	=================================================================
May  9 13:29:51 cogulla SpringBoard[2040]: HW kbd: Failed to set (null) as keyboard focus
May  9 13:29:51 cogulla com.apple.CoreSimulator.SimDevice.E1ED1960-E6EE-4974-8145-8C01530C48F1.launchd_sim[2024] (UIKitApplication:com.xamarin.acquaint-forms[0x1a13][2092]): Service exited due to signal: Abort trap: 6
May  9 13:29:51 cogulla SpringBoard[2040]: Application 'UIKitApplication:com.xamarin.acquaint-forms[0x1a13]' crashed.

Setup:

=== Xamarin Studio Business ===

Version 6.1 (build 817)
Installation UUID: 0a9ae72a-48a9-4853-ab6a-fe231f5fca0b
Runtime:
	Mono 4.4.0 (mono-4.4.0-branch/fcf7a6d) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404000148

=== NuGet ===

Version: 3.3.0.0

=== Xamarin.Profiler ===

Version: 0.33.1
Location: /Users/rodrigo/Projects/xamarin/profiler/src/XamarinProfiler.Mac/bin/Debug/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Xamarin.Android ===

Version: 6.1.0.40 (Xamarin Business)
Android SDK: /Users/rodrigo/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		5.0 (API level 21)
		5.1 (API level 22)
		6.0 (API level 23)

SDK Tools Version: 25.1.3
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.3

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 7.3.1 (10188.1)
Build 7D1014

=== Xamarin.Mac ===

Version: 2.9.0.719 (Xamarin Business)

=== Xamarin.iOS ===

Version: 9.9.0.719 (Xamarin Business)
Hash: 3afb4af
Branch: master
Build date: 2016-04-24 15:13:41-0400

=== Build Information ===

Release ID: 601000817
Git revision: 2335763551f9db8296b08542035977b899b7f3b7
Build date: 2016-04-25 10:45:36-04
Xamarin addins: 7f8c9ab2a981143a87fbd5adbde3f5890a838fde
Build lane: monodevelop-lion-cycle8-preview

=== Operating System ===

Mac OS X 10.11.4
Darwin cogulla.local 15.4.0 Darwin Kernel Version 15.4.0
    Fri Feb 26 22:08:05 PST 2016
    root:xnu-3248.40.184~3/RELEASE_X86_64 x86_64
Comment 1 Rodrigo Moya 2016-05-18 17:15:28 UTC
*** Bug 41106 has been marked as a duplicate of this bug. ***
Comment 2 Sebastien Pouliot 2016-08-16 14:08:13 UTC
That's a critical bug that was not commented in over a month ? @Alex ? @Kumpera ?
Comment 3 Alex Rønne Petersen 2016-08-30 04:58:04 UTC
This is the fix: https://github.com/mono/mono/pull/3466

Should make it into C8 if all goes to plan.
Comment 4 Alex Rønne Petersen 2016-09-01 14:12:03 UTC
Fix is in C8.
Comment 5 Saurabh 2016-09-05 07:03:20 UTC
I have checked this Issue with latest builds (XI 9.99.5.106 + XS 6.1.0.5398) I am not seeing any crash after clicking on snapshot icon in application as well as from profiler.

Environment Info and logs: https://gist.github.com/saurabh360/f3b1a00b5cd03a2fce1e01403bb39b5f
Profiler Log: https://gist.github.com/saurabh360/a47d0b40f7bcdacb782082223a313142