Bug 40944 - Profiler (v0.33) crashes with unhandled exception when selecting timerange on empty project
Summary: Profiler (v0.33) crashes with unhandled exception when selecting timerange on...
Status: VERIFIED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: Windows (show other bugs)
Version: unspecified
Hardware: PC Windows
: High critical
Target Milestone: (C8)
Assignee: Jose Miguel Torres
URL:
Depends on:
Blocks:
 
Reported: 2016-05-06 15:35 UTC by MrSmith
Modified: 2016-05-18 15:03 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description MrSmith 2016-05-06 15:35:25 UTC
Product: Xamarin Profiler
Version: 0.33

Reproduce:
1. Open Xamarin Profiler
2. Close, "Choose a Profiling Template" dialog
3. On Elapsed Time control, left-click and drag.

Actual Result:
Software throws an unhandled NullReferenceException in WindowsBase.dll, "Object reference not set to an instance of an object."

Workaround:
Dont go selecting time ranges when there isn't a project to load.

Exception Details:
System.NullReferenceException was unhandled
Message: An unhandled exception of type 'System.NullReferenceException' occurred in WindowsBase.dll
Additional information: Object reference not set to an instance of an object.
Comment 1 MrSmith 2016-05-06 15:36:02 UTC
Severity: low
Comment 2 xamarin-release-manager 2016-05-09 16:21:30 UTC
Fixed in version 0.33.1.22 (master)

Author: Jose Miguel Torres
Commit: b3b2c6f8c0a49108f588c2cb75b56567de56ee53 (xamarin/profiler)
Comment 3 asimk 2016-05-18 13:54:44 UTC
@MrSmith, I have checked this with last month profiler build but unable to reproduce this issue. Please review the screencast and let me know what additional steps we need to follow to reproduce this issue, so that we can verify this issue at our end.
Screencast: http://www.screencast.com/t/ryv9WucySeu
Comment 4 Tajinder Singh 2016-05-18 15:03:46 UTC
I have checked this issue with latest profiler build i.e.XamarinProfiler.Windows.Installer.0.33.1-38 and observed that this issue has been fixed now. Here is the screencast for the same: http://www.screencast.com/t/pCMmdnDL