Bug 40943 - On Windows Store 8.1 and Windows UWP, BorderWidth on Button is ignored
Summary: On Windows Store 8.1 and Windows UWP, BorderWidth on Button is ignored
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.2.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 30313 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-06 14:42 UTC by John Hardman
Modified: 2016-11-16 21:10 UTC (History)
6 users (show)

Tags: Windows Store Button BorderWidth BorderColor ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Hardman 2016-05-06 14:42:39 UTC
On Windows Store 8.1, Buttons are displayed with a visible Border, even though BorderWidth is set to 0.

The following is a dump of relevant properties of a Button in my app. The BorderColor is set to Color.Lime, but with both BorderWidth and BorderRadius set to 0, a Lime colored border is still displayed. With BorderWidth set to 0, I would not expect to see a border at all.

OffButton: 
Text = "RNo", 
TextColor = [Color: A=1, R=0, G=0, B=0, Hue=0, Saturation=0, Luminosity=0], 
BackgroundColor = [Color: A=1, R=0.752941191196442, G=0.752941191196442, B=0.752941191196442, Hue=0, Saturation=0, Luminosity=0.752941191196442], 
BorderColor = [Color: A=1, R=0, G=1, B=0, Hue=0.333333343267441, Saturation=1, Luminosity=0.5], 
Margin = (12,12,12,12), 
BorderWidth = 0, 
BorderRadius = 0, 
Height = 38
Comment 1 John Hardman 2016-05-06 14:47:31 UTC
The same happens on UWP as well.
Comment 2 Paul DiPietro [MSFT] 2016-11-14 17:54:10 UTC
*** Bug 30313 has been marked as a duplicate of this bug. ***
Comment 3 Samantha Houts [MSFT] 2016-11-16 21:10:33 UTC
Should be fixed in 2.3.4-pre1. Thank you!