Bug 40940 - Only a single unit test from a multiple selection is executed
Summary: Only a single unit test from a multiple selection is executed
Status: RESOLVED DUPLICATE of bug 27375
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: NUnit (show other bugs)
Version: unspecified
Hardware: PC Windows
: Normal enhancement
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-05-06 12:29 UTC by Jon Stoneman
Modified: 2017-10-05 13:58 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 27375

Description Jon Stoneman 2016-05-06 12:29:14 UTC
The Unit Tests pad allows multiple tests to be selected by using Command-Click.  If you then Command-Ctrl-Click -> Run Test, only a single test is executed.

I've seen this behaviour on Xamarin Studio 5.10.3 and 6.0 (build 5104).  With 6.0, the first (alphabetically) unit test is run.  With 5.10.3, I think it might have been the unit test that you Command-Ctrl-Clicked on that was run but I'm not sure about that.

Ideally, we should be able to select and execute multiple unit tests within a solution/project/namespace/class or from different projects/namespaces/classes.  If this is not possible then perhaps multiple selection should be disabled within the pad.
Comment 1 Lluis Sanchez 2017-10-05 13:58:45 UTC

*** This bug has been marked as a duplicate of bug 27375 ***