Bug 40933 - After installing Xamarin Studio, a copy of an installer script is left at the root of the system volume
Summary: After installing Xamarin Studio, a copy of an installer script is left at the...
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Rolf Bjarne Kvinge [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2016-05-06 10:50 UTC by matt
Modified: 2016-05-27 17:22 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
The preinstall script left in / (842 bytes, application/x-shellscript)
2016-05-06 10:50 UTC, matt
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description matt 2016-05-06 10:50:00 UTC
Created attachment 15931 [details]
The preinstall script left in /

I installed Xamarin Studio recently by downloading XamarinInstaller.dmg, double-clicking the installer app, and installing all components it said were available. I've just now come across a file at the root of my hard drive called "preinstall", which I've attached. It's not a huge issue, but ideally, the installer would only put files where you expect them.
Comment 1 Marek Habersack 2016-05-09 15:22:05 UTC
Hi,

This file is managed by OSX's own installer (/usr/sbin/installer) and is extracted from the .pkg archive. Neither Xamarin Studio nor the Xamarin Unified Installer work with this script directly. As such, there's nothing we can do as it's an issue with the native OS installer. Thanks!
Comment 2 matt 2016-05-10 01:48:41 UTC
That's a pretty dismissive thing to say. Couldn't someone, perhaps, actually put some effort in and look at the .pkg files which get extracted, find that there's an errant copy of an installer script at the root of the contents of one of those .pkg files, and then remove the file?

If it's an issue with the native installer, why have I never seen this occur with any other piece of software? If it's a bug with Apple's installer, have you filed a bug with Apple about it?

If you simply don't care about the issue, please at least be upfront about it.
Comment 3 matt 2016-05-10 04:44:13 UTC
Using Suspicious Package (http://www.mothersruin.com/software/SuspiciousPackage/) I looked at the .pkg files in the ~/Library/Caches/XamarinInstaller/Universal/downloads/ directory, and "xamarin.ios-9.6.1.9.pkg" contains the /preinstall file which shouldn't be there. This only took me a couple of minutes to look in to, and it's clearly not a problem caused by third party installer software.

Regardless of whether this gets fixed or not, I really hope that this lack of effort into investigating reported bugs isn't normal for Xamarin. At the very least, just say "nobody on the installer team cares about this" and mark it WONTFIX rather than wrongfully blaming third party software and disclaiming responsibility.
Comment 4 Marek Habersack 2016-05-10 15:53:04 UTC
I never said it was a *bug* in Apple installer (and, as such, I did *not* report it as a bug) but merely stated it was an "issue" - meaning the installer might have been aborted and not given a chance to clean up the file. 
Also, there's *nothing* suspicious about the script. It's is a standard *preinstallation* script contained in the XAR archive's (.pkg is XAR) payload. The .pkg contains a number of Payload and Scripts files which, in turn, contain pre and post installation scripts *extracted, executed and removed by the OSX installer*
However, to fully investigate the issue I will reassign this bug to the Xamarin.iOS team since this is where the issue (or a bug, if it is so determined) originates. Thank you for your time!
Comment 5 Rolf Bjarne Kvinge [MSFT] 2016-05-27 17:22:50 UTC
Fixed: https://github.com/xamarin/xamarin-macios/pull/97