Bug 40915 - Assembly Reference Aliases are not support
Summary: Assembly Reference Aliases are not support
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding (show other bugs)
Version: Trunk
Hardware: PC Mac OS
: Normal normal
Target Milestone: C7SR1
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2016-05-05 18:58 UTC by Marek Safar
Modified: 2016-06-28 11:20 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Aliases (47.56 KB, application/zip)
2016-06-22 09:01 UTC, Danish Akhtar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Marek Safar 2016-05-05 18:58:21 UTC
For .csproj with settings like

    <Reference Include="System">
      <HintPath>..\..\..\git\mono\mcs\class\lib\net_4_x\System.dll</HintPath>
      <Aliases>Myclass1</Aliases>
    </Reference>

XS does not display, allow to edit or even use Aliases values for compilation.
Comment 1 Lluis Sanchez 2016-05-06 11:34:52 UTC
I added support for editing in the property pad. Compilation works fine, xbuild takes care of it. However, looks like that aliases argument is not sent to roslyn, since in the "extern alias" declaration it complains about the alias not being defined. Reassigning to C# binding.
Comment 2 Mike Krüger 2016-05-09 06:03:11 UTC
I have this method:

public Task<IEnumerable<string>> GetReferencedAssemblies (ConfigurationSelector configuration, bool includeProjectReferences)

How do I get the aliases with that ? Right they're missing there.
Comment 3 Marek Safar 2016-05-09 06:18:52 UTC
What info am I supposed to provide?
Comment 4 Mike Krüger 2016-05-09 06:26:10 UTC
@mareks: 
Was more something for lluis :) - the project system is missing the required information from my side :/
Comment 5 xamarin-release-manager 2016-05-17 07:00:51 UTC
Fixed in version 6.1.0.842 (master)

Author: Mike Kr??ger
Commit: efbb038d92732ca88993fddf69faa3ab1eadf6b0 (mono/monodevelop)
Comment 6 xamarin-release-manager 2016-06-10 07:44:53 UTC
Fixed in version 6.0.1.31 (cycle7)

Author: Lluis Sanchez
Commit: 112ee0037a2c042c1ba2356eb66f5378bd317fb5 (mono/monodevelop)
Comment 7 xamarin-release-manager 2016-06-15 18:45:31 UTC
Fixed in version 6.0.2.19 (cycle7-app-insights-rebased)

Author: Lluis Sanchez
Commit: 112ee0037a2c042c1ba2356eb66f5378bd317fb5 (mono/monodevelop)
Comment 8 Danish Akhtar 2016-06-22 09:01:01 UTC
@Marek: I have tried to reproduce this issue but not sure about how to create Aliases in XS. So I have followed the steps mentioned here in https://blogs.msdn.microsoft.com/ansonh/2006/09/27/extern-alias-walkthrough.

I am successfully able to create Alias in VS by right clicking on References->properties->Aliases but I am not getting this option in XS.

Could you please suggest me, How should I create Aliases in XS? So that I can reproduce this issue and verified at our end.

I am also attaching my test project which I was created in VS.


Thanks!
Comment 9 Danish Akhtar 2016-06-22 09:01:42 UTC
Created attachment 16436 [details]
Aliases