Bug 40911 - NRE with Facebook Login
Summary: NRE with Facebook Login
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.2.0
Hardware: PC Mac OS
: Normal major
Target Milestone: ---
Assignee: Bugzilla
URL:
: 42214 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-05 16:57 UTC by Bill Holmes
Modified: 2016-11-24 17:01 UTC (History)
7 users (show)

Tags: ac iOS
Is this bug a regression?: ---
Last known good build:


Attachments
iOS app to reproduce issue (9.22 KB, application/zip)
2016-05-05 16:57 UTC, Bill Holmes
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Bill Holmes 2016-05-05 16:57:20 UTC
Created attachment 15916 [details]
iOS app to reproduce issue

Attached is a simplified test case that reproduces the issue.  

 - Compile and run the iOS app
 - Touch the first login button
 - Touch the second login button

After the blue page appears you will get a NRE.

I found that a null check on the following line avoids the issue, but feel the real fix is more complicated than that.

https://github.com/xamarin/Xamarin.Forms/blob/90d8976cf/Xamarin.Forms.Platform.iOS/Platform.cs#L330
Comment 1 E.Z. Hart [MSFT] 2016-08-26 22:08:59 UTC
*** Bug 42214 has been marked as a duplicate of this bug. ***
Comment 2 Rui Marinho 2016-09-27 13:51:34 UTC
Should be fixed in 2.3.4-pre1
Comment 3 Parmendra Kumar 2016-11-24 17:01:32 UTC
I have checked this issue with Xamarin.Forms 2.3.4-pre1 and this issue has been fixed.

Hence closing this issue.


Thanks.