Bug 4079 - xsp4 on Windows does not find mcs path
Summary: xsp4 on Windows does not find mcs path
Status: ASSIGNED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Web (show other bugs)
Version: master
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Duncan Mak
URL:
Depends on:
Blocks:
 
Reported: 2012-03-23 17:21 UTC by Timotheus Pokorra
Modified: 2012-05-21 12:24 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 4079 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
ASSIGNED

Description Timotheus Pokorra 2012-03-23 17:21:14 UTC
I have just installed Alpha 2.11.0 for Windows, and started xsp4.

For every aspx or asmx page I try to access, I get this message in the browser:

Application Exception
System.IO.FileNotFoundException
Windows mcs path not found: C:\Program Files (x86)\Mono-2.11\lib\lib\build\mcs.exe

Description: HTTP 500.Error processing request.

Details: Non-web exception. Exception origin (name of application or object): System.
Exception stack trace:
at Mono.CSharp.CSharpCodeCompiler..cctor () [0x00000] in <filename unknown>:0
Version Information: 2.11 ((no/02fe886); ASP.NET Version: 4.0.30319.1

I hope this helps.
Comment 1 Duncan Mak 2012-03-24 10:52:20 UTC
I'll look into fixing this.