Bug 40788 - Invalid assembly name System.ServiceModel.Web
Summary: Invalid assembly name System.ServiceModel.Web
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: BCL Class Libraries (show other bugs)
Version: XI 9.10 (C8)
Hardware: Macintosh Mac OS
: High blocker
Target Milestone: 10.0.0 (C8)
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2016-04-30 21:23 UTC by Frank A. Krueger
Modified: 2016-07-12 17:57 UTC (History)
8 users (show)

Tags: bry
Is this bug a regression?: ---
Last known good build:


Attachments
Picture showing the warning everywhere (59.71 KB, image/png)
2016-04-30 21:23 UTC, Frank A. Krueger
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Frank A. Krueger 2016-04-30 21:23:21 UTC
Created attachment 15874 [details]
Picture showing the warning everywhere

All of my F# code files show this warning now. This is a regression from the previous Alpha.

This bug prevents my app from working correctly.



=== Xamarin Studio Enterprise ===

Version 6.1 (build 817)
Installation UUID: 033a3a98-f63f-44a3-8bd3-bb3b731f3639
Runtime:
	Mono 4.4.0 (mono-4.4.0-branch/fcf7a6d) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404000148

=== NuGet ===

Version: 3.3.0.0

=== Xamarin.Profiler ===

Version: 0.32.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 7.3 (10183.3)
Build 7D175

=== Xamarin.Mac ===

Version: 2.9.0.719 (Xamarin Enterprise)

=== Xamarin.iOS ===

Version: 9.9.0.719 (Xamarin Enterprise)
Hash: 3afb4af
Branch: master
Build date: 2016-04-24 15:13:41-0400

=== Xamarin.Android ===

Version: 6.1.99.224 (Xamarin Enterprise)
Android SDK: /Users/fak/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 19.1

Java SDK: /usr
java version "1.8.0_20-ea"
Java(TM) SE Runtime Environment (build 1.8.0_20-ea-b23)
Java HotSpot(TM) 64-Bit Server VM (build 25.20-b22, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.3.7
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 601000817
Git revision: 2335763551f9db8296b08542035977b899b7f3b7
Build date: 2016-04-25 10:45:36-04
Xamarin addins: 7f8c9ab2a981143a87fbd5adbde3f5890a838fde
Build lane: monodevelop-lion-cycle8-preview

=== Operating System ===

Mac OS X 10.11.3
Darwin muon.local 15.3.0 Darwin Kernel Version 15.3.0
    Thu Dec 10 18:40:58 PST 2015
    root:xnu-3248.30.4~1/RELEASE_X86_64 x86_64
Comment 1 Sebastien Pouliot 2016-05-01 14:32:17 UTC
Hey Frank, this looks like an IDE only warning (that needs investigation + fixing) but how does it affects you application ? e.g. build or runtime error ?
Comment 3 Frank A. Krueger 2016-05-01 17:27:01 UTC
Sebastian: it only affects my app because it happens to be an IDE that displays this same warning in its GUI :-)


Gouri: I don't have an explicit reference to the asm.
Comment 4 Jason Imison 2016-05-01 18:32:33 UTC
Frank, how can I repro this?
Comment 6 Sebastien Pouliot 2016-05-02 13:08:55 UTC
This public key (used for IVT) changed in mono 4.5.0 (versus earlier release) and does not match what's shipped for the mobile profile.

castor:xamarin-macios poupou$ diff -u external/mono/mcs/class/System.Runtime.Serialization/Assembly/AssemblyInfo.cs ../mono/mcs/class/System.Runtime.Serialization/Assembly/AssemblyInfo.cs
--- external/mono/mcs/class/System.Runtime.Serialization/Assembly/AssemblyInfo.cs	2016-04-26 10:21:55.000000000 -0400
+++ ../mono/mcs/class/System.Runtime.Serialization/Assembly/AssemblyInfo.cs	2015-11-17 14:37:53.000000000 -0500
@@ -67,6 +67,6 @@
 // [assembly: InternalsVisibleTo ("System.ServiceModel, PublicKey=00000000000000000400000000000000")]
 #endif
 [assembly: InternalsVisibleTo ("System.ServiceModel, PublicKey=" + AssemblyRef.FrameworkPublicKeyFull)]
-[assembly: InternalsVisibleTo ("System.ServiceModel.Web, PublicKey=" + AssemblyRef.MicrosoftPublicKey)]
+[assembly: InternalsVisibleTo ("System.ServiceModel.Web, PublicKey=" + AssemblyRef.FrameworkPublicKeyFull)]
Comment 7 Marek Safar 2016-05-02 14:13:05 UTC
Fixed in mono master
Comment 8 Sebastien Pouliot 2016-05-03 23:59:05 UTC
Cherry-picked the two commits from master to mono-4.5.0-branch

[mono-4.5.0-branch b1b4398] [System.Runtime.Serialization] Remove redundant IVT to System.ServiceModel
[mono-4.5.0-branch f4252bf] [System.Runtime.Serialization] Remove redundant IVT to System.ServiceModel.Web

PR #24 merged in xamarin-macios/master e86f41c225faa5018a5b47f328c091fd13cb672d
Comment 9 GouriKumari 2016-07-07 20:38:29 UTC
@frank: Could you confirm whether the issue reported is resolved by the current XI build in alpha channel? This bug wasn't reproducible from QA end.
Comment 10 GouriKumari 2016-07-12 17:56:48 UTC
Since we couldn't reproduce the issue, I verified whether the fix is in place in alpha and the public key (used for IVT, mentioned in comment #6) seems to be disabled, hence I am closing this message.

Logs: diff -u mono/mcs/class/System.Runtime.Serialization/Assembly/AssemblyInfo.cs  xamarin-macios/external/mono/mcs/class/System.Runtime.Serialization/Assembly/AssemblyInfo.cs 
--- mono/mcs/class/System.Runtime.Serialization/Assembly/AssemblyInfo.cs	2016-07-12 13:10:23.000000000 -0400
+++ xamarin-macios/external/mono/mcs/class/System.Runtime.Serialization/Assembly/AssemblyInfo.cs	2016-06-07 17:09:30.000000000 -0400
@@ -62,11 +62,6 @@
 [assembly: AllowPartiallyTrustedCallers]
 [assembly: ComCompatibleVersion (1, 0, 3300, 0)]
 [assembly: SecurityCritical (SecurityCriticalScope.Explicit)]
-// for SyndicationElementExtension
-// FIXME: mcs in 2-10 branch breaks System.ServiceModel build on resolving this. So, disabling it so far.
-// [assembly: InternalsVisibleTo ("System.ServiceModel, PublicKey=00000000000000000400000000000000")]
 #endif
-[assembly: InternalsVisibleTo ("System.ServiceModel, PublicKey=" + AssemblyRef.FrameworkPublicKeyFull)]
-[assembly: InternalsVisibleTo ("System.ServiceModel.Web, PublicKey=" + AssemblyRef.MicrosoftPublicKey)]

##Test Env:
Builds compared:
XI 9.9.0.718 (Evolve preview) and XI 9.9.0.288
Comment 11 GouriKumari 2016-07-12 17:57:55 UTC
Update to comment#10 :

## Test Env:
XI 9.9.0288 (current alpha)