Bug 40749 - [Regression] Translation with resx files is broken (version 6.1.0.48)
Summary: [Regression] Translation with resx files is broken (version 6.1.0.48)
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: High normal
Target Milestone: 6.1 (C7)
Assignee: dean.ellis
URL:
: 40690 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-28 01:57 UTC by David CASBONNE
Modified: 2016-05-18 18:06 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description David CASBONNE 2016-04-28 01:57:50 UTC
Hi,

I don't really know if it's in Mono runtime or somewhere else but since I've upgraded to Xamarin.Android 6.1.0.48 (Beta channel) I'm not able to have my translations that are in an AppResources.fr.resx.

I've downgrade to 6.0.3.5 and everything is OK.

Can you fix this ASAP please ?
Comment 1 Peter Collins 2016-05-04 20:30:48 UTC
@David can you provide a little more context, or ideally a project which reproduces this issue? Also, does this only happen for builds which utilize fast assembly deployment? Or does this also affect Release deployments?

@Dean Could this be a dupe of https://bugzilla.xamarin.com/show_bug.cgi?id=40690?
Comment 2 dean.ellis 2016-05-04 20:39:12 UTC
@peterc that does look like a similar problem
Comment 3 David CASBONNE 2016-05-05 01:15:23 UTC
Hi Peter,

I have followed this tutorial : https://developer.xamarin.com/guides/xamarin-forms/advanced/localization/

I'm not really able to reproduce the bug since I'm on Xamarin Android 6.0.3.5 but in 6.1.0.48 the bug was here.
(it's a little hard to update Xamarin Android "just to reproduce" and then going back to 6.0.3.5 for the daily development).

I hope the previous link would help you to understand the bug.

Thanks a lot!
Comment 4 dean.ellis 2016-05-06 11:34:07 UTC
Fixed in monodroid/master/3946198145

@peterc do we need to get this in to cycle6/7?
Comment 5 dean.ellis 2016-05-06 11:36:36 UTC
*** Bug 40690 has been marked as a duplicate of this bug. ***
Comment 6 David CASBONNE 2016-05-07 04:06:33 UTC
Hi Dean,

Glad to hear you fix it !
Could you tell me in which version of Xamarin.Android is this bug solved ?

Thanks!
Comment 7 dean.ellis 2016-05-09 09:33:36 UTC
Hi David

We'll be testing it in our master branch then hopefully if it passed (which it will :) ) we can get it into the next Alpha/Beta release.
Comment 8 David CASBONNE 2016-05-09 12:25:36 UTC
Great !

Could you write here the Alpha/beta number in which it will be integrate please ? 
I will check the next beta to see it :)

Thanks !
Comment 9 Abhishek 2016-05-16 14:14:44 UTC
As per comment https://bugzilla.xamarin.com/show_bug.cgi?id=40690#c2
this issue is duplicate of bug 40690 and I have checked this issue with latest C7 build  now this issue is working fine.

Hence marking this issue as Verified.

Thanks
Comment 10 David CASBONNE 2016-05-17 00:52:13 UTC
Hi,

Is this disponible in the latest alpha or beta of Xamarin.Android ? 

Thanks,
Comment 11 Peter Collins 2016-05-17 20:57:25 UTC
This is not yet available in Alpha or Beta, but should be available in Beta in the coming weeks. I will provide an update here once this fix has been released.
Comment 12 David CASBONNE 2016-05-18 18:06:18 UTC
OK thanks! 

I will update as soon as you include this fix and provide a feedback here.

Note You need to log in before you can comment on or make changes to this bug.