Bug 40663 - 100% reliable crash on XamMac
Summary: 100% reliable crash on XamMac
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2016-04-24 18:52 UTC by Rodrigo Kumpera
Modified: 2016-04-24 21:19 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test case (927.22 KB, application/gzip)
2016-04-24 18:52 UTC, Rodrigo Kumpera
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 40663 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Rodrigo Kumpera 2016-04-24 18:52:28 UTC
Created attachment 15824 [details]
Test case

Run the attached project and click on the button. Always crash the debugger.
Comment 1 Rodrigo Kumpera 2016-04-24 18:53:27 UTC
Crash log: https://gist.github.com/kumpera/1cfb84ce75516b60cdf5b0b37329c72c
Comment 2 Zoltan Varga 2016-04-24 21:19:48 UTC
Looks similar to:
https://bugzilla.xamarin.com/show_bug.cgi?id=39172

We should test when we have a build with a fix for that one.