Bug 40486 - System.ExecutionEngineException: SIGILL on Samsung S7
Summary: System.ExecutionEngineException: SIGILL on Samsung S7
Status: RESOLVED DUPLICATE of bug 39859
Alias: None
Product: Forms
Classification: Xamarin
Component: Android (show other bugs)
Version: 2.1.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-04-18 15:17 UTC by Anatoliy
Modified: 2016-10-21 05:11 UTC (History)
19 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Anatoliy 2016-04-18 15:17:35 UTC
Hi.It's been almost one month since I found a serious issue with my app on some Samsung devices (mostly on Galaxy S7). I've described the problem a little bit here https://forums.xamarin.com/discussion/64215/app-doesnt-run-on-samsung-s7-sometimes?, and tried to solve this by myself while I'm waiting for any news about this issue from Xamarin team, because you guys are just keeping silence about any progress of solving this. I understand that according to my description it's hard to reproduce the issue, that is why I've tried to minimize the code of my app by excluding more and more code from the app every time I've got this SIGILL Exception.
So here you can download a sample app with SIGILL Exception on Samsung S7 https://goo.gl/Y0n7Qx. But, since this app has a really really small amount of code it's not that easy to catch this Expt, so you might need to run it atleast 50 times, but trust me, on a bigger project with a lot of code I'm getting this Expt in 8/10 times. And I'm getting it every time from different place of my project.

Also we are using Xamarin Insights for our project  and we have got a bunch of issues last time. And almost all of were affected on different Samsung devices Galaxy S-series. You can find some screenshots here https://goo.gl/z5TNqh and inside attached sample project.

I've tried so many different combinations, settings, updates. etc but still cannot figure it out what is happening with it, and what is so special with Samsung devices. I suspected Garbage collector, threading, style rendering, etc, but now I'm not sure about anything.

And luckily today I've got the same issue with one of Xamarin Forms samples https://developer.xamarin.com/samples/xamarin-forms/Navigation%5CTabbedPageWithNavigationPage/ (need to run many times before you can catch it on device), so I realized that it isn't some unique problem with my app only. And I'm sure it will be more people facing same problem (I wonder why I'm still alone with that), so It is better to be fixed ASAP. 

We are running release this week and I'm preparing myself for more and more complaining from users.
Comment 1 Marius Kahmen 2016-04-24 01:21:48 UTC
+1 on this.

same issue with my Galaxy S7 edge
Comment 2 Jorge 2016-05-04 12:50:52 UTC
The same happened to me, i dont have a device to test but from insight i know it's a SM-G935f.

I'm on Visual Studio 2015 and Xamarin.Forms v1.5.0.6447
Comment 3 Momm 2016-05-05 17:11:22 UTC
Same problem here with Samsung S7 (SM-G930F), Android 6.0.1.

Xamarin Studio Enterprise
Version 5.10.3 (build 51)

Project uses Xamarin.Forms 2.0.1.6505, Xamarin.Insights and targets API 23.

It doesn't seem to be related to Insights, because I removed it and it kept crashing.
Comment 4 Jerome Liger 2016-05-16 10:08:28 UTC
+1 (application with Tabs too)

same issue with Galaxy S7 (SM-G930F)
No problem with other androids (smartphone android 5, tablet android 6)

VS2013 + Xamarin v4.0.30319
Comment 5 Toubap 2016-06-02 12:58:18 UTC
Same thing happened to me.

I presumed I fixed this issue by removing ARM64-V8a from release build.

Just release the app update few days ago and not happened since.

I wait to see if it's really enough
Comment 6 Marius Kahmen 2016-06-02 13:08:05 UTC
@Toubap
the issue does not happen in a release (& signed) version.

It only occurs to me in Debug-Mode. Very annoying.
Comment 7 Jahmai 2016-08-07 08:41:18 UTC
It's happening on our release builds and we do not have arm64-v8a enabled.
Comment 8 Jahmai 2016-08-16 09:38:00 UTC
Is there an update on this issue? The crashes are getting out of hand.
Comment 9 ae 2016-08-17 07:47:54 UTC
Same problem here...
Comment 10 Jahmai 2016-08-17 09:15:15 UTC
I think this one should be marked as a duplicate of https://bugzilla.xamarin.com/show_bug.cgi?id=39859
Comment 11 Arthur 2016-08-24 05:56:11 UTC
Similar problem here:
App (Android, MvvmCross) runs fine on emulator and several non-Samsung S7 phones. However, on Samsung S7 it crashes at seemingly random places. All crashes have "android.runtime.JavaProxyThrowable: System.ExecutionEngineException: SIGILL" in common.
Comment 12 Dominic N [MSFT] 2016-08-25 23:25:23 UTC

*** This bug has been marked as a duplicate of bug 39859 ***
Comment 13 Philippe Creytens 2016-10-12 10:34:15 UTC
@Dominic Bug https://bugzilla.xamarin.com/show_bug.cgi?id=39859 states that it occurs when the app launches. Not randomly when the app is running. You have marked this as a duplicate, are you sure this is a duplicate of that same issue?
Comment 14 gavin 2016-10-21 05:11:25 UTC
Don't know if this is relevant or just a red herring, but it appears to happen when you include the V7 Support package. (Both Mvvmcross and Xamarin).

Note You need to log in before you can comment on or make changes to this bug.