Bug 40434 - CarouselView.Item throws a NullReferenceException
Summary: CarouselView.Item throws a NullReferenceException
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.2.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-04-15 13:11 UTC by David Britch
Modified: 2016-04-22 04:39 UTC (History)
5 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description David Britch 2016-04-15 13:11:55 UTC
Any attempts to examine the CarouselView.Item property in the debugger shows:

 System.NullReferenceException: Object reference not set to an instance of an object.

The source code is odd because the BindableProperty implementation has a TwoWay binding, but the CLR property only has a getter. In addition, the default value of the BindableProperty is null, so maybe it's never being set at all?
Comment 1 Samantha Houts [MSFT] 2016-04-18 18:45:18 UTC
Should be fixed in 2.2.0-pre3. Thank you!
Comment 2 Rajneesh Kumar 2016-04-22 04:39:23 UTC
Hi,to verify this issue, I have tried to reproduce this but not able to reproduce. Could you please share a small sample application that demonstrate this issue. That would be very helpful to reproduce/verify this issue at our end.

Thanks..!