This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 40414 - [C7] Quick Search does not work at all.
Summary: [C7] Quick Search does not work at all.
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Shell (show other bugs)
Version: 6.0.0 (C7)
Hardware: PC Mac OS
: High normal
Target Milestone: (C9)
Assignee: Marius Ungureanu
URL:
: 36282 36581 36922 37334 40114 40350 41126 41362 41726 41984 42407 42943 51469 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-14 22:12 UTC by Jeffrey Stedfast
Modified: 2017-02-14 09:58 UTC (History)
26 users (show)

See Also:
Tags: NotARegression potentialC8SR2
Is this bug a regression?: No
Last known good build:


Attachments

Description Jeffrey Stedfast 2016-04-14 22:12:49 UTC
Whenever I try to type something in the search bar, no text ever gets entered.
Comment 1 xamarin-release-manager 2016-04-15 15:41:16 UTC
Fixed in version 6.0.0.5047 (cycle7)

Author: Jeffrey Stedfast
Commit: 1bdf7b72a0025b62a62a5dbb3558657a3f247a42 (xamarin/md-addins)
Included in Commit: 342e50014a200402ac82c93da303681e1ea5179f (mono/monodevelop)
Comment 2 Jeffrey Stedfast 2016-04-15 15:42:20 UTC
Sorry, I typed the wrong bug # in my commit for bug #40440
Comment 3 Marius Ungureanu 2016-04-18 11:12:39 UTC
*** Bug 40114 has been marked as a duplicate of this bug. ***
Comment 4 Lluis Sanchez 2016-05-23 13:10:30 UTC
*** Bug 41126 has been marked as a duplicate of this bug. ***
Comment 5 mitchell balsam 2016-06-09 09:10:11 UTC
Not fixed in latest stable version.  Works for 30 min or so then Xamarin Studio needs to be restarted..  Very frustrating.

To be clear: Text can not be entered in search field in upper right corner of screen. You enter the field and try to type text for your search, no characters appear.
Comment 6 mitchell balsam 2016-06-09 09:12:41 UTC
Xamarin Studio Business
Version 6.0 (build 5174)
Installation UUID: 0c073893-2922-4898-8459-8855aaa4f143
Runtime:
	Mono 4.4.0 (mono-4.4.0-branch-c7-baseline/5995f74) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404000182

Xamarin.Profiler
Version: 0.0.0.0
Location: /Applications/XamarinProfiler.Mac.app/Contents/MacOS/XamarinProfiler.Mac

Xamarin.Android
Not Installed

Xamarin Android Player
Not Installed

Apple Developer Tools
Xcode 7.3 (10183.3)
Build 7D175

Xamarin.Mac
Not Installed

Xamarin.iOS
Version: 9.8.0.323 (Xamarin Business)
Hash: 39ebb77
Branch: cycle7
Build date: 2016-06-01 21:23:15-0400

Xamarin Inspector
Version: 0.8.1.0
Hash: 95792d1
Branch: master
Build date: Thu May 12 22:20:04 UTC 2016

Build Information
Release ID: 600005174
Git revision: 694a75f040b7f2309bc43d4f78a3a6572ca898bf
Build date: 2016-06-01 17:28:08-04
Xamarin addins: 33f406fa2dcf214012c78cb846585f062b2e1d24
Build lane: monodevelop-lion-cycle7-baseline

Operating System
Mac OS X 10.11.4
Darwin mbdevmac 15.4.0 Darwin Kernel Version 15.4.0
    Fri Feb 26 22:08:05 PST 2016
    root:xnu-3248.40.184~3/RELEASE_X86_64 x86_64

Enabled user installed addins
Xamarin Inspector 0.8.1.0
Comment 7 Lluis Sanchez 2016-06-09 09:30:58 UTC
*** Bug 41362 has been marked as a duplicate of this bug. ***
Comment 8 Marius Ungureanu 2016-06-09 12:59:58 UTC
*** Bug 40350 has been marked as a duplicate of this bug. ***
Comment 9 Lluis Sanchez 2016-06-13 08:54:44 UTC
*** Bug 41726 has been marked as a duplicate of this bug. ***
Comment 10 Lluis Sanchez 2016-06-20 08:44:00 UTC
*** Bug 41984 has been marked as a duplicate of this bug. ***
Comment 11 Lluis Sanchez 2016-08-04 14:49:04 UTC
*** Bug 42943 has been marked as a duplicate of this bug. ***
Comment 12 danielmoorhouse 2016-09-01 14:00:39 UTC
Bug still active in version 6.0.2 (build 73).

=== Xamarin Studio Community ===

Version 6.0.2 (build 73)
Installation UUID: c3b4e831-1cea-468b-a44f-a0897e33207c
Runtime:
	Mono 4.4.2 (mono-4.4.0-branch-c7sr1/f72fe45) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404020011

=== Xamarin.Profiler ===

Not Installed

=== Xamarin.Android ===

Version: 6.1.2.21 (Xamarin Studio Community)
Android SDK: /Users/User/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 25.1.7
SDK Platform Tools Version: 24.0.2
SDK Build Tools Version: 24.0.2

Java SDK: /usr
java version "1.8.0_102"
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 7.3.1 (10188.1)
Build 7D1014

=== Xamarin.Mac ===

Version: 2.8.2.22 (Xamarin Studio Community)

=== Xamarin.iOS ===

Version: 9.8.2.22 (Xamarin Studio Community)
Hash: f37444a
Branch: cycle7-sr1
Build date: 2016-07-28 12:17:02-0400

=== Build Information ===

Release ID: 600020073
Git revision: a6f7a24a9723a2d4f5d33c176615b0d44703ab5b
Build date: 2016-07-26 13:36:15-04
Xamarin addins: f5acb37866a0141bc5ddbe95118f18dae4014568
Build lane: monodevelop-lion-cycle7-sr1

=== Operating System ===

Mac OS X 10.11.6
Darwin DevMac 15.6.0 Darwin Kernel Version 15.6.0
    Thu Jun 23 18:25:34 PDT 2016
    root:xnu-3248.60.10~1/RELEASE_X86_64 x86_64
Comment 13 Jeffrey Stedfast 2016-09-01 21:11:43 UTC
Just hit this myself in the (C8) 6.1 Alphas :(
Comment 14 Tom Gilder 2016-11-17 11:37:07 UTC
This bug requires me to restart Xamarin Studio several times a day; and 5 times in the last 10 minutes. Hugely frustrating. Please please please fix.
Comment 15 Doron 2016-11-17 11:47:09 UTC
When the IDE gets to this state, you can't search at all. The omni search on top right does not work and also search in files does not work. So you basically have no way of finding any file or type and must restart the IDE.
Comment 16 Miguel de Icaza 2016-12-15 22:14:12 UTC
I wonder if someone has some steps to reproduce this?  I talked to the team and while they have looked at this, it has been hard to reproduce.

Meanwhile, I wonder if we could add some debug button so we can dump the responder chain
Comment 17 Tom Gilder 2016-12-15 22:16:54 UTC
I've tried but failed to figure out a reliable repro but failed, but it happens every single day for me, at seemingly random times. Very happy to help with any logs/dumps when it occurs.
Comment 18 mk 2016-12-20 13:29:30 UTC
Everybody in our team has seen this even with the latest stable release. I don't know how to reproduce this - it just stops working after some time. I have the impression it's related with a huge number of debug sessions or with suspending macOS during a short break and leaving Xamarin Studio open.
Comment 19 Marius Ungureanu 2017-01-13 16:32:19 UTC
*** Bug 51469 has been marked as a duplicate of this bug. ***
Comment 20 Marius Ungureanu 2017-01-13 17:18:51 UTC
Thanks to the repro from #51469, we have a fix. This will be deployed to all channels.

The searchbar corruption happens when opening build/signing panels for Android/iOS/Mac project options.
Comment 21 Andy 2017-01-13 21:47:26 UTC
I oftentimes get this issue without ever having opened build/signing panels.
Comment 22 Marius Ungureanu 2017-01-14 00:31:56 UTC
*** Bug 36282 has been marked as a duplicate of this bug. ***
Comment 23 Marius Ungureanu 2017-01-14 15:09:39 UTC
@Andy, you might have opened them by mistake (when traversing project options), this is the only root cause that would cause native keypresses to end up being ignored by Cocoa.
Comment 24 Marius Ungureanu 2017-01-16 12:23:20 UTC
The next build refresh on each channel should bring in the fix.
Comment 25 Shruti 2017-01-18 12:55:16 UTC
************************
Reproduce Status:
************************

I am successfully able to reproduce this issue at my end with Cycle 8 Build of XS version 6.1.4.0 following by the steps mentioned in comment0 of bug:https://bugzilla.xamarin.com/show_bug.cgi?id=51469

=======Supplement Info=======
Screencast: https://www.screencast.com/t/HMZ3lpoy

=======Build Information=======
Version 6.3 (build 580)
Release ID: 601040000
Git revision: 26be89d0803fe047db1182518ea6493c390d1e9b
Build date: 2017-01-09 10:24:44-05
Xamarin addins: 9a6061e5bb44a806bdf4a4ffffc9357099ffb3e5
Build lane: monodevelop-lion-cycle8

************************
Verification Status:
************************

I have verified this issue with latest C9 and Master build of XS and observed that this issue is no more reproducible on both the lanes.

=======Supplement Info=======
Screencast: https://www.screencast.com/t/WUQN5cWqe

=======Cycle 9 Build Information=======
XS Version 6.2 (build 1757)
Release ID: 602001757
Git revision: d769a24532f7b7a9933fc9187631b4175fb94be6
Build date: 2017-01-17 15:00:00-05
Xamarin addins: 3fda1860d20ac17fb238c320a021b07d96dc9e53
Build lane: monodevelop-lion-cycle9

=======Master Build Information=======
XS Version 6.3 (build 580)
Release ID: 603000580
Git revision: 3e7356f194963afa375c8127124e01af2e992832
Build date: 2017-01-17 17:28:06-05
Xamarin addins: 8d98ab67cd27bae97f3de688d7b870471edf6286
Build lane: monodevelop-lion-master

Hence, changing the bug status to verified fixed.

Thanks!
Comment 26 Naqeeb 2017-01-18 17:23:47 UTC
I have checked this issue with build XamarinStudio-6.1.5.0 and observed that it is working fine. Here is the screencast for the same: https://www.screencast.com/t/jO3H7yvmZZF

Environment info: https://gist.github.com/NaqeebAnsari/178c40a7655f07a71136b4e3acb89eee
Comment 27 Marius Ungureanu 2017-02-14 08:29:05 UTC
*** Bug 42407 has been marked as a duplicate of this bug. ***
Comment 28 Marius Ungureanu 2017-02-14 08:56:22 UTC
*** Bug 36581 has been marked as a duplicate of this bug. ***
Comment 29 Marius Ungureanu 2017-02-14 09:57:02 UTC
*** Bug 36922 has been marked as a duplicate of this bug. ***
Comment 30 Marius Ungureanu 2017-02-14 09:58:39 UTC
*** Bug 37334 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.