Bug 40374 - Crash while loading a project
Summary: Crash while loading a project
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: (C8)
Assignee: Lluis Sanchez
URL:
: 41911 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-14 02:03 UTC by Alan McGovern
Modified: 2016-08-10 14:55 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Alan McGovern 2016-04-14 02:03:16 UTC
I was debugging XS within XS and loaded up a solution. I hit a null reference here: https://gist.github.com/alanmcgovern/8716840266568b0de4b06f645ed0d499 because `OwnerProject` is null.
Comment 1 Lluis Sanchez 2016-07-14 07:34:14 UTC
*** Bug 41911 has been marked as a duplicate of this bug. ***
Comment 2 xamarin-release-manager 2016-07-14 08:36:23 UTC
Fixed in version 6.2.0.173 (master)

Author: Lluis Sanchez
Commit: 90d690e56f2e100d8dea11bf3ad690f9eefaeb4f (mono/monodevelop)
Comment 3 xamarin-release-manager 2016-07-14 08:36:52 UTC
Fixed in version 6.1.0.5229 (cycle8)

Author: Lluis Sanchez
Commit: 803dc02ffc60920fa0b90119d729124f310935a6 (mono/monodevelop)
Comment 5 Shruti 2016-08-10 05:29:24 UTC
@Alan, Could you please check this issue at your end. I believe it should be working fine as we are not experiencing this issue here.
Comment 6 Mohit Kheterpal 2016-08-10 14:55:23 UTC
As this issue does not have any specific reproduction steps.

So we checked this issue by loading multiple project in XS while execution of smoke test plan and do not found any regression issue.

Hence closing this issue by marking it as Verified Fixed.

thanks