Bug 40251 - Cannot style Buttons natively using UIButton.Appearance
Summary: Cannot style Buttons natively using UIButton.Appearance
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: unspecified
Hardware: All All
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-04-08 22:43 UTC by Joe Manke
Modified: 2017-07-13 07:18 UTC (History)
6 users (show)

Tags: ac iOS
Is this bug a regression?: ---
Last known good build:


Attachments
Reproduction with workaround renderer (11.85 KB, application/zip)
2016-04-08 22:47 UTC, Joe Manke
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Joe Manke 2016-04-08 22:43:44 UTC
OVERVIEW: 
Attempts to use the Appearance proxy in native iOS to style buttons fails, due to the use of UIButtonType.RoundedRect when constructing the native control in the default ButtonRenderer.  UIButtonType.RoundedRect was deprecated in iOS 7, and replaced by UIButtonType.System, which ignores properties from the Appearance. Therefore, using the Appearance property to attempt to style buttons in a Xamarin.Forms app fails.

EXPECTED BEHAVIOR:
When properties are set on UIButton.Appearance, Button properties should match this when not set explicitly otherwise.

ACTUAL BEHAVIOR:
Button properties do not match UIButton.Appearance.

Example: 
> UIButton.Appearance.SetTintColor(UIColor.Red, UIControlState.Normal);
Default Button.TextColor appears as blue.

SOLUTION: 
In the ButtonRenderer, replace
> this.SetNativeControl(new UIButton(UIButtonType.RoundedRect));
with
> this.SetNativeControl(new UIButton(UIButtonType.Custom));

WORKAROUND:
Extend ButtonRenderer, use UIButton.Appearance in default cases. See attachment.

RELATED: https://bugzilla.xamarin.com/show_bug.cgi?id=25209
Comment 1 Joe Manke 2016-04-08 22:47:40 UTC
Created attachment 15663 [details]
Reproduction with workaround renderer
Comment 2 adrianknight89 2016-11-21 05:39:57 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/554
Comment 3 Rui Marinho 2017-03-20 16:01:49 UTC
Should be fixed on 2.3.5-pre1
Comment 4 Jacky Waswani 2017-07-13 07:18:45 UTC
Have verified the bug with latest forms build version 2.3.5.256-pre6.

Issue is seems to be fixed with latest build.

Screen cast : https://www.screencast.com/t/NldOZDhQGOcM

Build Info: https://gist.github.com/gangrade-swati/4c84bc1572bfab6ebf93774e9fe22af6