Bug 40234 - Strings get corrupted sometimes
Summary: Strings get corrupted sometimes
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-04-08 11:20 UTC by Jason Imison
Modified: 2016-04-08 11:59 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Corrupted string in XS (51.45 KB, image/png)
2016-04-08 11:20 UTC, Jason Imison
Details
FAKE screenshot in terminal (22.88 KB, image/png)
2016-04-08 11:21 UTC, Jason Imison
Details
Corruption in the terminal (86.42 KB, image/png)
2016-04-08 11:22 UTC, Jason Imison
Details
50/50 (192.91 KB, image/png)
2016-04-08 11:23 UTC, Jason Imison
Details
FAKE script running inside the XS GUI (351.20 KB, image/png)
2016-04-08 11:24 UTC, Jason Imison
Details

Description Jason Imison 2016-04-08 11:20:23 UTC
Created attachment 15653 [details]
Corrupted string in XS

I can't come up with a reliable repro for this problem, but I've seen it a couple of times and seen reports from others that all look like the same issue.

I've seen the issue with the following FAKE script (and others), but this looks to be an issue in the runtime because I've seen screenshots of corrupted strings in Xamarin Studio too (see attachment)

// include Fake lib
#r @"tools/FAKE/tools/FakeLib.dll"
open Fake
open FileUtils
open Fake.Git

let ok,output,errors = Fake.Git.CommandHelper.runGitCommand "." "--version"
output |> Seq.iter trace

Target "Marker" ( fun _ -> trace "Build Complete")

"Marker"

RunTargetOrDefault "Marker"

I ran this script twice. I saw the problem the first time, but not again. I ran the script in a loop for 5 minutes or so and didn't see it again. All reports that I've seen have been on OSX, but unsure if it's limited to that platform.
Comment 1 Jason Imison 2016-04-08 11:21:16 UTC
Created attachment 15654 [details]
FAKE screenshot in terminal
Comment 2 Jason Imison 2016-04-08 11:22:32 UTC
Created attachment 15655 [details]
Corruption in the terminal
Comment 3 Jason Imison 2016-04-08 11:23:17 UTC
Created attachment 15656 [details]
50/50
Comment 4 Jason Imison 2016-04-08 11:24:38 UTC
Created attachment 15657 [details]
FAKE script running inside the XS GUI

Can't be a terminal / encoding issue.

Note You need to log in before you can comment on or make changes to this bug.