This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 40139 - Changing the Windows 10 System Theme Color causes ListView text to disappear.
Summary: Changing the Windows 10 System Theme Color causes ListView text to disappear.
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows (show other bugs)
Version: 2.1.0
Hardware: PC Windows
: Normal normal
Target Milestone: UWP
Assignee: Bugzilla
URL:
: 43409 43420 44973 48428 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-06 02:53 UTC by Jon Goldberger [MSFT]
Modified: 2017-07-21 18:52 UTC (History)
15 users (show)

See Also:
Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Test Project (93.53 KB, application/zip)
2016-04-06 02:53 UTC, Jon Goldberger [MSFT]
Details

Description Jon Goldberger [MSFT] 2016-04-06 02:53:13 UTC
Created attachment 15620 [details]
Test Project

## Description

Changing the Windows 10 System Theme Color causes ListView text to disappear.

## Steps to reproduce.

1. Open the attached test project in Visual Studio 2015 on a Windows 10 machine.

2. Launch the UWP app project to the Local Machine.

3. Observe the list view with several identical items in the list.

4. Click the Windows Start button and select Settings

5. Select Personalization.

6. Select Colors.

7. Click on any of the three Switch controls, e.g. "Automatically pick an accent color from my background"

Expected result: Text in ListView items will still be visible.

Actual result: Text in ListView items are not visible. 

## Environment

Forms version 2.1.0.6529

Microsoft Visual Studio Professional 2015
Version 14.0.25123.00 Update 2
Microsoft .NET Framework
Version 4.6.01038

Installed Version: Professional

Visual Basic 2015   00322-40000-00000-AA850
Microsoft Visual Basic 2015

Visual C# 2015   00322-40000-00000-AA850
Microsoft Visual C# 2015

Visual C++ 2015   00322-40000-00000-AA850
Microsoft Visual C++ 2015

Visual F# 2015   00322-40000-00000-AA850
Microsoft Visual F# 2015

Windows Phone SDK 8.0 - ENU   00322-40000-00000-AA850
Windows Phone SDK 8.0 - ENU

Application Insights Tools for Visual Studio Package   5.2.60328.3
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 2015.1 (Beta8)   14.1.11106.0
ASP.NET and Web Tools 2015.1 (Beta8)

ASP.NET Web Frameworks and Tools 2012.2   4.1.41102.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.40314.0
For additional information, visit http://www.asp.net/

Common Azure Tools   1.7
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

GitHub.VisualStudio   1.0
A Visual Studio Extension that brings the GitHub Flow into Visual Studio.

JavaScript Language Service   2.0
JavaScript Language Service

JavaScript Project System   2.0
JavaScript Project System

Microsoft Azure Mobile Services Tools   1.4
Microsoft Azure Mobile Services Tools

NuGet Package Manager   3.4.0
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools   14.0.60311.1
Microsoft SQL Server Data Tools

TypeScript   1.8.29.0
TypeScript tools for Visual Studio

Visual Studio Tools for Universal Windows Apps   14.0.25123.00
The Visual Studio Tools for Universal Windows apps allow you to build a single universal app experience that can reach every device running Windows 10: phone, tablet, PC, and more. It includes the Microsoft Windows 10 Software Development Kit.

Xamarin   4.0.3.214 (0dd817c)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   6.0.3.5 (a94a03b)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS   9.6.1.8 (3a25bf1)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 2 Phillip Hallam-Baker 2016-06-09 19:54:16 UTC
Seeing the same problem with the expansion toggles in TreeView. 

Also on Windows 10, using Visual Studio.

Looking at the Gtk.CellRenderer Cell, the Foreground and background both have the alpha channel set to 0. Setting it to 1 does not fix the problem.
Comment 3 guillaume.nicolas 2016-07-01 12:40:17 UTC
Same problem for me. On Windows 10, set Background Color to Cell doesn't solve the problem. it's really Text that desapear.
Comment 4 Paul DiPietro [MSFT] 2016-08-16 14:23:50 UTC
*** Bug 43409 has been marked as a duplicate of this bug. ***
Comment 5 E.Z. Hart 2016-08-16 20:51:11 UTC
*** Bug 43420 has been marked as a duplicate of this bug. ***
Comment 6 Paul DiPietro [MSFT] 2017-01-19 18:05:15 UTC
*** Bug 48428 has been marked as a duplicate of this bug. ***
Comment 7 Frank Folsche 2017-01-27 15:26:35 UTC
Hi, this being worked on?

I need to decide if I'm going to build a build alternative listview for my UWP app or postpone the release of my UWP app, until a fix is released.

As this is a very common way of building UWP apps I think the statement that Xamarin forms supports UWP should be removed.
Comment 8 Samantha Houts 2017-02-01 18:19:46 UTC
https://github.com/xamarin/Xamarin.Forms/pull/731
Comment 9 Samantha Houts 2017-02-03 18:20:37 UTC
Should be fixed in 2.3.5-pre1. Thank you!
Comment 10 E.Z. Hart 2017-04-12 15:47:49 UTC
*** Bug 44973 has been marked as a duplicate of this bug. ***
Comment 11 Saurabh Paunikar 2017-07-13 07:57:27 UTC
This issue still occurs , hence reopening the bug

Environment info :https://gist.github.com/saurabh-paunikar/4932c704b6a205cf61457a008c16f8be

Diagnostic output logs :

https://gist.github.com/saurabh-paunikar/a62521aade0ae28f02136852cfbb744c

Screencast link : https://www.screencast.com/t/tUsOj5krO
Comment 12 Paul DiPietro [MSFT] 2017-07-13 17:01:16 UTC
I've just tested this again against the originally provided reproduction and 2.3.5-pre6 and it works as expected. Changing the accent color does not cause the cell text to disappear. I can only assume something is being cached incorrectly or something to that effect. Please try completely wiping your bin/obj/package folders, deleting the app, and that the same package version is being used across the solution.
Comment 13 Saurabh Paunikar 2017-07-18 10:27:36 UTC
Verified on xamarin.form version 2.3.5.256-pre6.

ScreenCast link : https://www.screencast.com/t/LZEOqPvxMwIg
Comment 14 Sahin Ozdemir 2017-07-21 09:23:13 UTC
it seems that with the pre6 version the ListViewSelectedItemBehavior command now fires twice in a row when you click on a listview item. This makes our app crash due to unexpected behavior.

Can this be fixed?
Comment 15 Jon Goldberger [MSFT] 2017-07-21 18:52:42 UTC
@Sahin Ozdemir

That sounds like a different issue. Please file a new bug report with a simple test project that demonstrates the issue and please provide steps to reproduce the issue.

Note You need to log in before you can comment on or make changes to this bug.