Bug 39908 - Back button hit quickly results in jumbled pages
Summary: Back button hit quickly results in jumbled pages
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.3.5
Hardware: PC Mac OS
: Highest normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
: 42341 50090 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-03-25 02:16 UTC by Cody Beyer (MSFT)
Modified: 2018-01-02 11:38 UTC (History)
13 users (show)

Tags: ac, ios, navigation fr
Is this bug a regression?: ---
Last known good build:


Attachments
sample (26.95 KB, application/zip)
2016-03-25 02:16 UTC, Cody Beyer (MSFT)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Cody Beyer (MSFT) 2016-03-25 02:16:19 UTC
Created attachment 15523 [details]
sample

# Description

The attached samples demonstrates an issue, that when several pages are added to a navigation stack and then removed quickly, pages will go missing and otherwise become jumbled

# Video

https://www.dropbox.com/s/0yh5yezm0vtmvx8/BackFails.mov?dl=0

# Sample

Attached

# Steps to Reproduce

1. Download sample
2. Deploy to iOS
3. Click “Another One” 6 times
4. Click the navigation back button quickly
5. Click “Another One” 6 times
6. Click the navigation back button quickly

# Expected Results

Pages should be removed from the stack sequentially and added again sequentially 

# Actual Results

Pages are skipped and otherwise jumbled

# Versions

=== Xamarin Studio ===

Version 6.0 (build 4801)
Installation UUID: 6ed47d68-9b2d-49fb-b805-3689139ceefa
Runtime:
	Mono 4.4.0 (mono-4.4.0-branch/f8474c4) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 404000040

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.3 (10183.3)
Build 7D175

=== Xamarin.iOS ===

Version: 9.6.0.0 (Business Edition)
Hash: d7cac50
Branch: master
Build date: 2016-03-21 20:13:04-0400

=== Xamarin.Android ===

Version: 6.0.2.1 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.4.1.7 (Business Edition)

=== Build Information ===

Release ID: 600004801
Git revision: f73f730c738baf8701a5892b7af64fd468d1dc0c
Build date: 2016-03-14 14:28:06-04
Xamarin addins: 3af7be6c701eb0137645a03e38b82f23b65738c3
Build lane: monodevelop-lion-cycle7

=== Operating System ===

Mac OS X 10.11.4
Darwin Codys-MacBookPro.local 15.4.0 Darwin Kernel Version 15.4.0
	Fri Feb 26 22:08:05 PST 2016
	root:xnu-3248.40.184~3/RELEASE_X86_64 x86_64
Comment 1 Rui Marinho 2016-08-10 16:11:32 UTC
*** Bug 42341 has been marked as a duplicate of this bug. ***
Comment 2 Samantha Houts [MSFT] 2016-08-17 18:40:43 UTC
Should be fixed in 2.3.3-pre1. Thank you!
Comment 3 Parmendra Kumar 2016-09-20 15:16:54 UTC
I have checked this issue with Xamarin.Forms 2.3.3-pre2 and its working fine.

Hence closing this issue.
Comment 4 adrianknight89 2016-12-04 04:09:58 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/600
Comment 5 adrianknight89 2016-12-17 00:34:12 UTC
I think we need to use PopToViewController in addition to PopViewController to fix this.
Comment 6 Samantha Houts [MSFT] 2016-12-29 00:19:49 UTC
*** Bug 50090 has been marked as a duplicate of this bug. ***
Comment 7 David Ortinau [MSFT] 2017-06-16 19:03:40 UTC
I am seeing this issue in 2.3.5.239. Confirming and we'll give it another look.
Comment 8 Diego 2017-08-10 15:44:23 UTC
This issue is still happening in the latest stable Xamarin Forms version 2.3.4.224 so far.

Is there any workaround using custom renderers or any other way?
Comment 9 Jimmy [MSFT] 2017-08-17 00:02:49 UTC
Reverting status back to CONFIRMED since the pull request in comment 4 was not accepted.
Comment 10 Samantha Houts [MSFT] 2017-09-11 20:34:32 UTC
https://github.com/xamarin/Xamarin.Forms/pull/1029
Comment 11 mwesolowski 2017-10-05 07:07:32 UTC
Any ETA?
Comment 12 Rui Marinho 2018-01-02 11:38:09 UTC
Should be fixed on 2.6.0-pre1