Bug 39802 - Gap between ListView cells even if SeparatorVisablity is set to none
Summary: Gap between ListView cells even if SeparatorVisablity is set to none
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.3.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
: 41992 55935 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-03-21 10:23 UTC by John Eriksson
Modified: 2017-10-26 20:42 UTC (History)
17 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Test project that show a simple ListView containing colored cells that should be displayed with no gaps between them. (211.53 KB, application/x-zip-compressed)
2016-03-21 10:25 UTC, John Eriksson
Details
Separator on Android shown always when using GroupHeader (52.54 KB, image/png)
2017-06-01 08:43 UTC, Matthew
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Eriksson 2016-03-21 10:23:00 UTC
We are trying to a make a simple ListView without a gap between the cells.

When setting SeparatorVisibility="None", the separator disapears, but there are still a transperent 1-pixel gap betwen the cells in some cases.

On Android there's Always the 1-pixel gap, on iOS the gap is only there if we use CachingStrategy="RecycleElement".

See the attached Project for an example.
Comment 1 John Eriksson 2016-03-21 10:25:13 UTC
Created attachment 15470 [details]
Test project that show a simple ListView containing colored cells that should be displayed with no gaps between them.
Comment 2 John Eriksson 2016-03-22 06:57:20 UTC
Further information about what I have tried so far to accomplish this can be found in this forum thread: 

http://forums.xamarin.com/discussion/63080/remove-gap-between-cells-in-listview
Comment 4 Samantha Houts [MSFT] 2016-04-08 19:16:19 UTC
Oops! Closed the wrong bug report. Please disregard. Reopening.
Comment 5 Rui Marinho 2016-06-17 16:36:21 UTC
Should be fixed in 2.3.1-pre1
Comment 6 Samantha Houts [MSFT] 2016-06-24 16:57:09 UTC
*** Bug 41992 has been marked as a duplicate of this bug. ***
Comment 7 Samantha Houts [MSFT] 2016-06-24 17:10:22 UTC
*** Bug 42117 has been marked as a duplicate of this bug. ***
Comment 8 Parmendra Kumar 2016-07-01 06:49:44 UTC
I have checked this issue with Xamarin.Forms 2.3.1-pre1 and its working fine.

Hence closing this issue.
Comment 9 Tristan 2016-08-11 05:21:24 UTC
I'm still experiencing this bug in 2.3.1.114 on iOS with RecycleElement.
Comment 10 Parmendra Kumar 2016-08-11 13:09:36 UTC
@Tristan,

I have checked this issue with Xamarin.Forms 2.3.1.114 and this issue worked fine at my end.

Screencast: http://www.screencast.com/t/8klWrGvG

Could you please attach your sample project? so that I can reproduce this issue at my end.

Thanks.
Comment 11 John Hardman 2016-08-25 10:40:12 UTC
I am still seeing the one pixel gap on Android after upgrading to 2.3.1.114
Comment 12 Rui Marinho 2016-09-13 11:04:17 UTC
Hi i had to reopen this because the fix caused a regression on iOS 10, the trick i used was reset the frame to hide the gap, but some reason it doesn't like on iOS10, i m looking for another fix. I will also revise the Android version.
Comment 13 Matthew 2016-09-20 12:13:11 UTC
On Android if SeparatorVisablity = None and you use a Group Header the separator is still rendered. The closest I can get to hiding it is setting SeparatorColor = Transparent.
Comment 14 Assem Hakmeh 2017-02-20 08:39:08 UTC
Still experiencing this issue on iOS with Forms 2.3.3.193. Please fix.
Comment 16 Matthew 2017-05-31 08:11:22 UTC
The pull request only includes iOS changes, yet the issue affects Android if using Group Headers.
Comment 17 Rui Marinho 2017-05-31 14:04:39 UTC
Matthew, can you give me a exemple and a screenshot looks good for me on android with group headers
Comment 18 Jimmy [MSFT] 2017-05-31 15:17:06 UTC
*** Bug 55935 has been marked as a duplicate of this bug. ***
Comment 19 Matthew 2017-06-01 08:43:29 UTC
Created attachment 22613 [details]
Separator on Android shown always when using GroupHeader

I have attached a screenshot taken from an Android 4.4.4 emulator. The  application uses AppCompat and the listview has been set to show no separators at all. You will notice the green lines under the headers, this is a separator that is still rendered even when separators are disabled. If you change ListView.SeparatorColor = xxx then this line will change colour, so it is the separator being rendered here.

It is not possible to upload the code associated with my application but it's not doing anything fancy beyond using a group header on the list view.
Comment 20 Rui Marinho 2017-06-14 23:05:35 UTC
Should be fixed on 2.3.6-pre1
Comment 21 Jorge Lopes 2017-10-26 17:10:44 UTC
I am still seeing the one pixel gap on Android after upgrading to 2.4.0.18342 :(
Comment 22 Jorge Lopes 2017-10-26 18:02:10 UTC
It's not just "ListView", it's "TableView" also included "ListView".
I can not remove a transparent 1 pixel line.
Comment 23 clay.zuvich 2017-10-26 20:42:41 UTC
I'm still seeing it as well.