Bug 39768 - PanGestureRecognizer sometimes won't fire completed event when dragging very slowly
Summary: PanGestureRecognizer sometimes won't fire completed event when dragging very ...
Status: RESOLVED ANSWERED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.1.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 60841 60896 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-03-18 17:14 UTC by Paul DiPietro [MSFT]
Modified: 2018-01-07 22:48 UTC (History)
19 users (show)

See Also:
Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments

Description Paul DiPietro [MSFT] 2016-03-18 17:14:42 UTC
When panning, sometimes the PanGestureRecognizer won't reach its completed state when dragging very slowly. This is noticeable on at least Android, but supposedly occurs on Win 8.1 and WP 8.1.

Project to use, for ease: https://developer.xamarin.com/samples/xamarin-forms/WorkingWithGestures/PanGesture/

To Reproduce:
Add debug logs or breakpoints at the Gesture.Completed case in the PanContainer.cs's OnPanUpdated method.
When running the application, start a pan, hold it for a moment or two, and release.

Expected behavior:
The completed state is reached.

Resulting behavior:
Occasionally/frequently, this state is not reached.
Comment 2 David Stetz 2016-07-08 00:15:00 UTC
I am experiencing this issue as well. Is there a planned fix for this?
Comment 3 Chris Turner 2016-08-07 16:42:53 UTC
I can't believe that this bug has been around so long!!

The recognizer detects GestureStatus.Running without a problem so it sounds like a simple fix to make sure the GestureStatus.Completed state fires the updated event.

Xamarin Forms is a great idea but you cannot leave bugs like this hanging around for months at a time or people will stop developing with it.

Has anyone found a work-around?
Comment 4 Samantha Houts [MSFT] 2016-08-23 00:26:26 UTC
I can't seem to reproduce this for Windows platforms, but I can confirm Android has this issue.
Comment 6 Samantha Houts [MSFT] 2016-10-04 18:59:08 UTC
Should be fixed in 2.3.3-pre3. Thank you!
Comment 7 Parmendra Kumar 2016-11-03 14:41:49 UTC
I have checked this issue with Xamarin.forms 2.3.3-pre3 and observed that this issue has been fixed. I have checked this issue with NexusP (Android 7.0).

Hence closing this issue.
Comment 8 Pavel Sich 2017-07-10 12:35:55 UTC
It is NOT fixed, version 2.3.4 and still easily reproducible on Android 6 and 7.
Comment 9 Richard Pike 2017-11-28 17:10:54 UTC
This bug has come back as of 2.4.0.280 and persists into 2.5.
Reproducible on Android 4.4 and 7
Comment 10 Paul DiPietro [MSFT] 2017-11-28 17:23:38 UTC
*** Bug 60896 has been marked as a duplicate of this bug. ***
Comment 11 Paul DiPietro [MSFT] 2017-11-28 22:40:47 UTC
*** Bug 60841 has been marked as a duplicate of this bug. ***
Comment 12 daspuru 2018-01-02 18:57:30 UTC
Hi all, I hope this bug can be resolved soon... it still happening in these versions:

Xamarin.Forms 2.5.0.121934
Xamarin support libraries 26.1.0.1
Android SDK 26 (8.0)
Comment 13 Paul DiPietro [MSFT] 2018-01-04 02:45:01 UTC
Migrated to https://github.com/xamarin/Xamarin.Forms/issues/1495 for future tracking
Comment 14 Russell Corbin 2018-01-04 05:30:14 UTC
I can confirm this is still an issue on 2.5.0 on Android.

Note You need to log in before you can comment on or make changes to this bug.