Bug 39727 - ppdb debugging crashes with * Assertion at debugger-agent.c:8520, condition `locals->locals [i].index < header->num_locals' not met
Summary: ppdb debugging crashes with * Assertion at debugger-agent.c:8520, condition `...
Status: RESOLVED NORESPONSE
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2016-03-17 16:29 UTC by Marek Safar
Modified: 2017-10-11 20:05 UTC (History)
6 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Marek Safar 2016-03-17 16:29:16 UTC
I don't have simple repro yet but it's happens very often
Comment 1 Zoltan Varga 2016-03-21 10:46:00 UTC
Probly a dup of:
https://bugzilla.xamarin.com/show_bug.cgi?id=39570
Comment 2 Zoltan Varga 2016-03-21 11:08:15 UTC
Seems like a dup of:
https://bugzilla.xamarin.com/show_bug.cgi?id=39729
i.e. reverting to a commit before the commit in that bug also fixes this.
Comment 3 Zoltan Varga 2016-03-23 18:04:46 UTC
Did this got fixed by the fix for #39729 ?
Comment 4 Marek Safar 2016-03-23 18:47:21 UTC
Quite unlikely as I saw it today with 4.3.2 version
Comment 5 Dylan Borg 2016-08-07 08:52:38 UTC
It is still happening with the latest code, but with a different assertion.
Comment 6 Bernhard Urban 2016-09-07 21:54:18 UTC
what's the assertion?
Comment 7 Rodrigo Kumpera 2017-10-11 17:34:56 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and reopen the bug report.

Thank you!
Comment 8 Dylan Borg 2017-10-11 20:05:58 UTC
This has been fixed a long time ago.

Note You need to log in before you can comment on or make changes to this bug.