Bug 39705 - [Feature Request] Add a nine-patch editor so an Asset Catalog Image Set image can be sliced up like can be done in XCode.
Summary: [Feature Request] Add a nine-patch editor so an Asset Catalog Image Set image...
Status: RESOLVED ANSWERED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 4.0.0 (C6)
Hardware: PC Windows
: --- enhancement
Target Milestone: Future Cycle
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-03-17 01:16 UTC by Jon Goldberger [MSFT]
Modified: 2017-10-06 01:18 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Jon Goldberger [MSFT] 2016-03-17 01:16:41 UTC
## Description

XCode has a nice feature in that you can easily create a 9-patch for an image in an image set right in the Asset Catalog editor. See: https://developer.apple.com/library/ios/recipes/xcode_help-image_catalog-1.0/chapters/SlicinganImage.html

It would be nice to have such a feature in XVS as well. It would also be cool to have in XS, but since this can be done in XCode, it seems more important to have this feature in VS to avoid a user having to move to another workstation to make a 9-patch from an Image Set.
Comment 1 Joaquin Jares 2017-06-28 14:54:06 UTC
Moving to Future Cycle.
Comment 2 Pierce Boggan [MSFT] 2017-10-06 01:18:18 UTC
Thanks for taking the time to report this issue. :)

Jimmy Garrido will be adding this to our VSTS backlog, as it is a feature request or enhancement.