Bug 39508 - [XS 5.10.3] iOS 6 and iOS 7 devices are not displayed in the devices drop-down menu, device logs show repeating error "set_response_error: handle_get_value GetProhibited"
Summary: [XS 5.10.3] iOS 6 and iOS 7 devices are not displayed in the devices drop-dow...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in (show other bugs)
Version: 5.10 (C6SR3)
Hardware: PC Mac OS
: --- normal
Target Milestone: (C7)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-03-10 07:50 UTC by Mikalai
Modified: 2016-03-23 05:39 UTC (History)
7 users (show)

See Also:
Tags: BZRC6SR2S1_C6SR1S1
Is this bug a regression?: ---
Last known good build:


Attachments

Description Mikalai 2016-03-10 07:50:27 UTC
After updating to latest stable Xamarin I no longer can use my iOS device for debugging. Xcode log shows endless stream of such messages while Xamarin is running:


Mar 10 10:37:41 AntonUs-iPod lockdownd[43] <Notice>: 014c2000 set_response_error: handle_get_value GetProhibited
Mar 10 10:37:41 AntonUs-iPod lockdownd[43] <Notice>: 014c2000 set_response_error: handle_get_value GetProhibited
Mar 10 10:37:41 AntonUs-iPod lockdownd[43] <Notice>: 014c2000 set_response_error: handle_get_value GetProhibited
Mar 10 10:37:41 AntonUs-iPod lockdownd[43] <Notice>: 014c2000 set_response_error: handle_get_value GetProhibited
Mar 10 10:37:41 AntonUs-iPod lockdownd[43] <Notice>: 014c2000 set_response_error: handle_get_value GetProhibited
Mar 10 10:37:41 AntonUs-iPod lockdownd[43] <Notice>: 014c2000 set_response_error: handle_get_value GetProhibited
Mar 10 10:37:41 AntonUs-iPod lockdownd[43] <Notice>: 014c2000 set_response_error: handle_get_value GetProhibited
Mar 10 10:37:41 AntonUs-iPod lockdownd[43] <Notice>: 014c2000 set_response_error: handle_get_value GetProhibited
Mar 10 10:37:41 AntonUs-iPod lockdownd[43] <Notice>: 014c2000 set_response_error: handle_get_value GetProhibited

=== Xamarin Studio ===

Version 5.10.3 (build 26)
Installation UUID: 57f8a532-50d2-4e6b-8fe4-6526f8f6b880
Runtime:
	Mono 4.2.3 (explicit/832de4b)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402030004

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.2.1 (9548.1)
Build 7C1002

=== Xamarin.iOS ===

Version: 9.4.2.27 (Enterprise Edition)
Hash: 58ba2bc
Branch: master
Build date: 2016-03-03 09:05:19-0500

=== Xamarin.Android ===

Version: 6.0.2.1 (Enterprise Edition)
Android SDK: /Users/mikalai/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.3.4
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Not Installed

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 510030026
Git revision: ac9b7fcba9ee92ac30c8eb90f20c2228ce033efa
Build date: 2016-03-01 18:02:09-05
Xamarin addins: 633fde3bf405e3c402a51980976c431c204cf4f6
Build lane: monodevelop-lion-cycle6-c6sr2

=== Operating System ===

Mac OS X 10.11.3
Darwin Mikalais-MacBook-Pro.local 15.3.0 Darwin Kernel Version 15.3.0
    Thu Dec 10 18:40:58 PST 2015
    root:xnu-3248.30.4~1/RELEASE_X86_64 x86_64
Comment 1 Mikalai 2016-03-10 07:52:00 UTC
Device is iPod Touch 4th gen with iOS 6.1.3
Comment 2 Rolf Bjarne Kvinge [MSFT] 2016-03-10 09:33:53 UTC
I have a few questions to track this down:

1. Do you have other devices you can test with to see if it's an issue with a specific device and/or iOS version?

2. At exactly which point do those messages start appearing in the Xcode log:
  a) When Xamarin Studio is launched?
  b) When you open an iOS project?
  c) When launching/debugging an iOS project?
Comment 3 Mikalai 2016-03-10 10:32:44 UTC
1. Checked on:
 other iPod with iOS 6.1.6 - same issue.
 iPhone 6+ iOS 9.2.1 - everything is fine.

2. a) When Xamarin Studio is launched.
If I open iOS project while device is attached, Xamarin UI becomes almost unusable - activity monitor shows 100% cpu usage. But if the device is attached later, Studio behaves good.
 Logs are still spammed in both cases, and "Debug" box shows generic "iOS Device"
Comment 4 Rolf Bjarne Kvinge [MSFT] 2016-03-10 10:41:41 UTC
Thanks; Reassigning to Xamarin Studio since that's where the problem seems to be.
Comment 5 Jeffrey Stedfast 2016-03-10 15:56:01 UTC
Can you try the latest Xamarin Studio Alpha? 5.10.x probably won't be getting any more releases.
Comment 6 leankitryan 2016-03-11 17:02:57 UTC
We are seeing the same issue on an iPod Touch iOS, 5th generation, 7.1.2.

Rolling back to 5.9.8.0 resolves the issue.

Switching to alpha (6.0, build 4761) does not resolve the issue.
Comment 7 leankitryan 2016-03-11 19:34:20 UTC
We have a few test devices here running iOS 7 - a couple of iPod Touches, an iPhone, and an iPad mini. Xamarin Studio 5.10 doesn't recognize any of them. Xcode still does. This is a big deal for us since the iOS 7 simulators do not work on El Capitan. We have no way to test i0S 7 without downgrading.
Comment 8 Lorentz Morrow 2016-03-16 16:32:03 UTC
I see this was assigned to Xamarin Studio but I also see the same issue with an iPhone running iOS 7 when using Visual Studio.
Comment 9 Brendan Zagaeski (Xamarin Support) 2016-03-16 20:40:18 UTC
For cross-referencing, the issue in Visual Studio is being tracked in Bug 39655 (also linked in the "See Also" field).
Comment 10 Brendan Zagaeski (Xamarin Support) 2016-03-16 23:17:11 UTC
For thorough bookkeeping:

I can replicate this behavior locally, so I will confirm the bug.



## Regression status: regression between Xamarin Studio 5.10.2 and 5.10.3 

As expected based on the earlier comments, the Xamarin.iOS version does not seem to affect this behavior.


### Tests with latest Cycle 7 preview Xamarin.iOS 

> BAD:  Xamarin Studio 6.0 (build 4801)  (f73f730) + Xamarin.iOS 9.8.0.58 (fa3b68c) + Xcode 7.2
> BAD:  Xamarin Studio 5.10.3 (build 26) (ac9b7fc) + Xamarin.iOS 9.8.0.58 (fa3b68c) + Xcode 7.2
> GOOD: Xamarin Studio 5.10.2 (build 56) (bb74ff4) + Xamarin.iOS 9.8.0.58 (fa3b68c) + Xcode 7.2


### Tests with "Cycle 6 – Service Release 2" Xamarin.iOS

> BAD:  Xamarin Studio 5.10.3 (build 26) (ac9b7fc) + Xamarin.iOS 9.4.2.27 (58ba2bc) + Xcode 7.2 
> GOOD: Xamarin Studio 5.10.2 (build 56) (bb74ff4) + Xamarin.iOS 9.4.2.27 (58ba2bc) + Xcode 7.2


### Tests with "Cycle 6 – Service Release 1" Xamarin.iOS

> BAD:  Xamarin Studio 5.10.3 (build 26) (ac9b7fc) + Xamarin.iOS 9.4.1.25 (962a050) + Xcode 7.2
> GOOD: Xamarin Studio 5.10.2 (build 56) (bb74ff4) + Xamarin.iOS 9.4.1.25 (962a050) + Xcode 7.2




## `mtouch --listdev` works as expected

Again as expected (since the Xamarin.iOS version does not affect the behavior), running `mtouch --listdev` from the command line does correctly show the device:

> $ /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mtouch --listdev
> iPhone 4: 22370b3744bb0ac7defe0a4b8e617daebadaa1ee




## Additional testing environment info (brief)

### Devices tested

iPhone 4, iOS 7.1

### OS X 10.10.5

Mono 4.4.0 (f8474c4) (64-bit)
Comment 12 xamarin-release-manager 2016-03-17 21:01:21 UTC
Fixed in version 5.10.3.27 (cycle6-c6sr2)

Author: Jeffrey Stedfast
Commit: 8dc6bca63f5cd93719a093973e74de6999864193 (mono/monodevelop)
Comment 13 Danish Akhtar 2016-03-18 05:24:07 UTC
I am also able to reproduce this issue with XS 5.10.3.6. However with XS 5.10.3.27 this issue is not exits iOS 7 device is displaying in the devices drop-down menu of XS.

Environment info:=== Xamarin Studio ===

Version 5.10.3 (build 27)
Installation UUID: 46d4d4b6-9307-4ad8-8136-09022b256dbf
Runtime:
	Mono 4.2.3 (explicit/832de4b)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402030004

=== Xamarin.Profiler ===

Version: 0.29.99
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 7.2 (9548)
Build 7C68

=== Xamarin.iOS ===

Version: 9.4.2.27 (Starter Edition)
Hash: 58ba2bc
Branch: master
Build date: 2016-03-03 09:05:19-0500

=== Xamarin.Android ===

Version: 6.1.0.16 (Starter Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.1
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.8.0.58 (Starter Edition)

=== Build Information ===

Release ID: 510030027
Git revision: 8dc6bca63f5cd93719a093973e74de6999864193
Build date: 2016-03-17 17:13:33-04
Xamarin addins: 45239909442742bdee83a0c0f77eecb8a08bedfa
Build lane: monodevelop-lion-cycle6-c6sr2

=== Operating System ===

Mac OS X 10.10.5
Darwin Danish.local 14.5.0 Darwin Kernel Version 14.5.0
    Wed Jul 29 02:26:53 PDT 2015
    root:xnu-2782.40.9~1/RELEASE_X86_64 x86_64
Comment 14 Danish Akhtar 2016-03-18 05:25:28 UTC
Checked with iPhone 4v 7.1.2
Comment 15 xamarin-release-manager 2016-03-21 20:01:44 UTC
Fixed in version 5.10.3.33 (cycle6)

Author: Jeffrey Stedfast
Commit: a48950cf2fef2b96a67b73ca1bf4ad8351548f20 (xamarin/maciostools)
Included in Commit: 4c4abd19d7ce8690ff0c7aea6db7009ad2e25fc1 (mono/monodevelop)
Comment 16 Danish Akhtar 2016-03-23 05:39:33 UTC
This is also woking fine with XS 5.10.3(build 46) iOS 7 device is displaying in the devices drop-down menu of XS and we are successfully able to build/run the application.

Environment info:
=== Xamarin Studio Enterprise ===

Version 5.10.3 (build 46)
Installation UUID: 5aee9e7c-04d2-4896-b80a-a918340ae634
Runtime:
	Mono 4.2.3 (explicit/832de4b)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402030004

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.3 (10183.3)
Build 7D175

=== Xamarin.iOS ===

Version: 9.6.1.7 (Xamarin Enterprise)
Hash: 92addcd
Branch: master
Build date: 2016-03-22 20:56:19-0400

=== Xamarin.Android ===

Version: 6.0.2.1 (Xamarin Enterprise)
Android SDK: /Users/360_macmini/Desktop/setup/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
		6.0    (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

Android Designer EPL code available here:
https://github.com/xamarin/AndroidDesigner.EPL

=== Xamarin Android Player ===

Version: 0.6.1
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.4.2.1 (Xamarin Enterprise)

=== Build Information ===

Release ID: 510030046
Git revision: 9ebdc2952e60c64ddd8d0e41ddeceea5fcee499d
Build date: 2016-03-22 23:02:48-04
Xamarin addins: 4f94dceeec4d095571624a8579d7a7889dc3243b
Build lane: monodevelop-lion-cycle6-c6sr3

=== Operating System ===

Mac OS X 10.11.4
Darwin 360-MACMINIs-Mac-mini-2.local 15.4.0 Darwin Kernel Version 15.4.0
    Fri Feb 12 15:56:47 PST 2016
    root:xnu-3248.40.183~6/RELEASE_X86_64 x86_64

Note You need to log in before you can comment on or make changes to this bug.