Bug 39483 - ListView Context Menu localization
Summary: ListView Context Menu localization
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.1.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-03-09 12:37 UTC by Joe Maier
Modified: 2016-12-09 14:46 UTC (History)
8 users (show)

Tags: ios ac
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot showing the MORE and CANCEL items (193.53 KB, image/png)
2016-03-09 12:37 UTC, Joe Maier
Details
Screenshot showing the bug in the DemoApp (103.06 KB, image/png)
2016-03-12 12:21 UTC, Joe Maier
Details
Demo project to reproduce the bug (29.85 KB, application/zip)
2016-03-12 12:28 UTC, Joe Maier
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Joe Maier 2016-03-09 12:37:52 UTC
Created attachment 15329 [details]
Screenshot showing the MORE and CANCEL items

The "MORE" and "CANCEL" context menu items in a ListView's context menu are not localized.
They always appear in English and don't honour the underlying OS's language.
This was tested under iOS.

Please either take the underlying OS's text strings or expose these strings as properties, so they can be localized by the app.

Screenshot is attached.

Thanks,
Joe
Comment 1 E.Z. Hart [MSFT] 2016-03-10 20:52:46 UTC
Thank you for taking the time to submit the bug. We tried to reproduce the issue you reported but were unable given the description. If you could please attach a reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue we would very much appreciate it.

Warm regards,
Xamarin Forms Team
Comment 2 Joe Maier 2016-03-12 12:21:30 UTC
Created attachment 15386 [details]
Screenshot showing the bug in the DemoApp
Comment 3 Joe Maier 2016-03-12 12:28:21 UTC
Created attachment 15387 [details]
Demo project to reproduce the bug

Please change your simulator's locale to a non-English language to reproduce the bug.
Comment 4 E.Z. Hart [MSFT] 2016-03-15 18:59:23 UTC
Confirmed on iOS set to German; 'More' and 'Cancel' are not localized.
Comment 5 Samantha Houts [MSFT] 2016-03-25 23:19:48 UTC
Should be fixed in 2.2.0-pre1
Comment 6 Parmendra Kumar 2016-04-08 14:59:01 UTC
I have checked this issue with xamarin.forms 2.2.0-pre1 and I am still facing same issue.

Screencast: http://www.screencast.com/t/7moSva0K9H

Hence reopening this issue.

Please follow the screencast and let me know if I have missed anything.
Comment 7 Joe Maier 2016-04-09 10:11:34 UTC
@Parmendra: Thanks for testing. 
You followed the steps to reproduce the issue exactly, so the bug seems to be still there.

Instead of a "Should be fixed" note, a more detailed description of HOW it was fixed would be helpful. Meaning: The localization is done automatically, OR the developer has now additional properties which he/she must localize manually.

Best regards,
Joe
Comment 8 E.Z. Hart [MSFT] 2016-04-11 18:14:00 UTC
(In reply to Joe Maier from comment #7)
> @Parmendra: Thanks for testing. 
> You followed the steps to reproduce the issue exactly, so the bug seems to
> be still there.
> 
> Instead of a "Should be fixed" note, a more detailed description of HOW it
> was fixed would be helpful. Meaning: The localization is done automatically,
> OR the developer has now additional properties which he/she must localize
> manually.
> 
> Best regards,
> Joe

Joe, 

The localization should be handled automatically; you shouldn't have to do anything in order to see the localized button labels. Unfortunately, while the problem is fixed in code, we now have a deployment issue with the localized string assemblies and NuGet. We're working to address that now.
Comment 9 adrianknight89 2016-12-05 06:39:23 UTC
@hartez Has there been any change on the assembly issue since April?
Comment 10 E.Z. Hart [MSFT] 2016-12-09 00:07:29 UTC
Yes, this was fixed back in April: https://github.com/xamarin/Xamarin.Forms/pull/74

Bad bookkeeping on my part.
Comment 11 Parmendra Kumar 2016-12-09 14:46:50 UTC
I have checked this issue with Xmarin.Forms 2.3.3.175 and its working fine. This issue has been fixed.


Hence marked this issue as Verified Fixed.