Bug 39338 - SIGSEGV within VideoToolbox
Summary: SIGSEGV within VideoToolbox
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: XI 9.4 (iOS 9.2)
Hardware: PC Mac OS
: Normal normal
Target Milestone: C6SR3
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-03-03 22:14 UTC by Cody Beyer (MSFT)
Modified: 2016-03-23 10:20 UTC (History)
4 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample (2.82 MB, application/zip)
2016-03-03 22:14 UTC, Cody Beyer (MSFT)
Details

Description Cody Beyer (MSFT) 2016-03-03 22:14:48 UTC
Created attachment 15245 [details]
Sample

# Description

Using the below attached sample, running the app on a device will result in a crash while executing native code

# Error

https://gist.github.com/anonymous/75d518de61ee26100c06

# Sample 

Attached

# Steps to Reproduce

1. Download sample
2. Run on iOS Device

# Excpected Results

App should execute 

# Actual Results

App crashes during launch

# Versions

=== Xamarin Studio ===

Version 6.0 (build 4520)
Installation UUID: ae0fa433-e78e-4353-a756-7b47170e264a
Runtime:
	Mono 4.3.2 (mono-4.3.2-branch/ba2e5e4) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 403020467

=== Xamarin.Profiler ===

Not Installed

=== Apple Developer Tools ===

Xcode 7.2.1 (9548.1)
Build 7C1002

=== Xamarin.iOS ===

Version: 9.4.1.25 (Business Edition)
Hash: 962a050
Branch: master
Build date: 2016-01-29 16:59:11-0500

=== Xamarin.Android ===

Version: 6.0.1.10 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		4.0.3 (API level 15)
		4.4   (API level 19)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.0.1
SDK Build Tools Version: 23.0.1

Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.4.1.6 (Business Edition)

=== Build Information ===

Release ID: 600004520
Git revision: a354b2cb9df4b96f50b0ccb960dbdd5a9155510c
Build date: 2016-02-18 14:52:07-05
Xamarin addins: 8e54979f23feee160d245a3c33e43e77779b1eb4
Build lane: monodevelop-lion-master

=== Operating System ===

Mac OS X 10.11.3
Darwin clb-mbp.local 15.3.0 Darwin Kernel Version 15.3.0
	Thu Dec 10 18:40:58 PST 2015
	root:xnu-3248.30.4~1/RELEASE_X86_64 x86_64
Comment 1 Sebastien Pouliot 2016-03-03 23:20:16 UTC
> Version: 9.4.1.25 (Business Edition)
Comment 2 Sebastien Pouliot 2016-03-04 01:46:48 UTC
This was fixed in cycle 7. You can use the version in the alpha channel to get the fix today.
Comment 3 asimk 2016-03-23 10:20:37 UTC
we have checked this issue with attached sample using C6SR3 and C7 latest builds. App is getting deploy successfully on device.

Environment Info:
Device iPad Mini iOS 9.3

C6SR3 Env Info:https://gist.github.com/Udham1/82fb0c70e1e62deaca71
C7 Env Info: https://gist.github.com/Udham1/5edb3ad0be1048b5068b

Hence, I am closing this issue.

Note You need to log in before you can comment on or make changes to this bug.