Bug 39190 - SignalR
Summary: SignalR
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Web (show other bugs)
Version: 4.2.0 (C6)
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-29 06:22 UTC by brian leung
Modified: 2017-09-01 11:39 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 39190 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description brian leung 2016-02-29 06:22:58 UTC
This is a continued bug report of 33809 about SignalR.  I repeat the original report here:

===================
SignalR 2.x uses OWIN and requires the implementation of the method System.Web.HttpApplication.RegisterModule(), which is already done in Mono 4.2.0.

However, there is another exception when I tried to run the SignalR 2.x Tutorial project with Mono 4.2.0.  Details:
https://github.com/luckyus/mono420_signalR2.git

This is the SignalR 2.x tutorial project I used:
http://www.asp.net/signalr/overview/getting-started/tutorial-getting-started-with-signalr

Thank you.
====================

As seen in the 33809 report, part of the problem relating to Microsoft.Owin.Host.SystemWeb has been fixed by Marcos.  However, the next problem appears that "but the script in signalr/hub never finishes loading" (as stated in this previous report).

Please Help.

Thank you.