Bug 38923 - Web Reference files added to project appear red
Summary: Web Reference files added to project appear red
Status: RESOLVED DUPLICATE of bug 36116
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General (show other bugs)
Version: 5.10 (C6SR3)
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-19 15:52 UTC by John Miller [MSFT]
Modified: 2016-03-14 09:10 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description John Miller [MSFT] 2016-02-19 15:52:23 UTC
**Overview:**

   When a .NET 2.0 web reference is added, the generated files are added as links to the project and appear red, like they are missing. 

**Steps to Reproduce:**

   See private comments in https://bugzilla.xamarin.com/show_bug.cgi?id=38920 which will allow you to reproduce this.

**Actual Results:**

   The generated files that are added appear red, but are in fact not missing. 

**Expected Results:**

   The file names should not appear red.

**Build Date & Platform:**

=== Xamarin Studio ===

Version 5.10.2 (build 56)
Installation UUID: e01c3049-a2d2-4e0a-aad8-afe6fb627c4d
Runtime:
	Mono 4.2.2 (explicit/996df3c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 402020030

=== Xamarin.Profiler ===

Version: 0.30.0
Location: /Applications/Xamarin Profiler.app/Contents/MacOS/Xamarin Profiler

=== Apple Developer Tools ===

Xcode 7.2 (9548)
Build 7C68

=== Xamarin.Mac ===

Version: 2.4.1.6 (Business Edition)

=== Xamarin.iOS ===

Version: 9.4.1.25 (Business Edition)
Hash: 962a050
Branch: master
Build date: 2016-01-29 16:59:11-0500

=== Xamarin.Android ===

Version: 6.0.1.10 (Business Edition)
Android SDK: /Users/johnmiller/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.4   (API level 19)
		5.0   (API level 21)
		5.1   (API level 22)
		6.0   (API level 23)

SDK Tools Version: 24.4.1
SDK Platform Tools Version: 23.1
SDK Build Tools Version: 23.0.2

Java SDK: /usr
java version "1.8.0_60"
Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)

=== Xamarin Android Player ===

Version: 0.6.5
Location: /Applications/Xamarin Android Player.app

=== Xamarin Inspector ===

Version: 0.3.2.3
Hash: 1b526e6
Branch: master
Build date: Tue Nov 17 20:54:30 UTC 2015

=== Build Information ===

Release ID: 510020056
Git revision: bb74ff467c62ded42b7b7ac7fdd2edc60f8647b0
Build date: 2016-01-26 16:24:41-05
Xamarin addins: 8b797d7ba24d5abab226c2cf9fda77f666263f1b
Build lane: monodevelop-lion-cycle6-c6sr1

=== Operating System ===

Mac OS X 10.11.2
Comment 1 Matt Ward 2016-02-19 20:29:33 UTC
This is caused by a bug #36116 in Mono. Mono 4.2 generates incorrect filenames in the Reference.map file. The filenames start with a '/' so Xamarin Studio resolves the files to the root directory and since the files do not exist they are shown in red.

*** This bug has been marked as a duplicate of bug 36116 ***
Comment 2 Jacques Theyse 2016-03-08 10:50:32 UTC
Any idea when this issue will be resolved as we're stuck in limbo as far has feature updates on our apps are concerned.
Comment 3 Matt Ward 2016-03-08 10:56:00 UTC
Bug #36116, of which this is a duplicate, is marked as scheduled for Cycle 6 Service Release 2 which should be released to the stable channel now.
Comment 4 Jacques Theyse 2016-03-13 18:10:09 UTC
Good day, 

The errors in the solution explorer has disappeared, but the parameters referenced to the methods are still incorrect.

Test with web service
http://shcloudservice.cloudapp.net/SHCloudService.svc

1) Right-Click Web References
2) Add Web Reference
3) Web Service URL : http://shcloudservice.cloudapp.net/SHCloudService.svc
4) FrameWork: .NET 2.0 Web Services
5) Reference: ServiceWS

Actual method parameters: TestMethod(string _usr, string _pw, int _usr_id, string _gui_id, out string _status)

Returned when referenced: TestMethod (string _usr, string _pw, int _user_id, bool _usr_idSpecified (incorrect) ... ,string _gui_id, out string _status) 

This issue remains still unresolved.
Comment 5 Jacques Theyse 2016-03-14 09:10:48 UTC
It's been 4 months now and we still can't referenced our updated web service, thus not being able to expand our apps functionality.

Note You need to log in before you can comment on or make changes to this bug.