Bug 38753 - [XVS 4.0] Clicking "Xamarin for Visual Studio Update Available" notification toolbar icon in the system tray has no effect
Summary: [XVS 4.0] Clicking "Xamarin for Visual Studio Update Available" notification ...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Updater (show other bugs)
Version: 4.0.0 (C6)
Hardware: PC Windows
: --- normal
Target Milestone: 4.1.2 (C7SR1)
Assignee: Bugzilla
URL:
: 37798 (view as bug list)
Depends on:
Blocks: 38773
  Show dependency tree
 
Reported: 2016-02-15 09:24 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2016-08-30 01:56 UTC (History)
10 users (show)

Tags: BZRC6S1_C5SR5S1
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot of the Xamarin update notification icon (7.58 KB, image/png)
2016-02-15 09:24 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2016-02-15 09:24:46 UTC
Created attachment 15041 [details]
Screenshot of the Xamarin update notification icon

[XVS 4.0] Clicking "Xamarin for Visual Studio Update Available" notification toolbar icon in the system tray has no effect




## Regression status: regression in Cycle 6

BAD:  XamarinVS master/3b2082e28c59fd72b4e71a695f615a2029ed1cdc
BAD:  XamarinVS 4.0.1.74    (9f3b5a0)
BAD:  XamarinVS 4.0.0.1689  (f860fe4)
GOOD: XamarinVS 3.11.1594.0 (a06d6d5)




## Steps to replicate

1. Install a version of Xamarin that is different than the current Stable version.

2. Open a Xamarin project in Visual Studio.

3. Wait for the "Xamarin for Visual Studio Update Available" notification to appear in the system tray area of the task bar.

4. Click the icon once or double-click it.




## Results

There is no apparent response from the UI.




## Expected results

The update dialog appears, the same as if a user navigated through the menus to run "Tools -> Options -> Xamarin -> Other -> Check Now".
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2016-02-15 09:28:48 UTC
*** Bug 37798 has been marked as a duplicate of this bug. ***
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2016-02-19 00:30:10 UTC
## Workaround

Navigate to the update dialog using the Tools menu:

"Tools -> Options -> Xamarin -> Other -> Check Now"
Comment 4 adrianknight89 2016-02-27 16:56:15 UTC
I have this issue on VS2015. Clicking the notification bar doesn't work.
Comment 5 xamarin-release-manager 2016-03-16 13:02:59 UTC
Fixed in version 99.0.0.1785 (master)

Author: Brendan Zagaeski
Commit: 5d647e9d81a55da407aee461328ec06c4bd3df68 (xamarin/XamarinVS)
Comment 7 xamarin-release-manager 2016-04-15 18:52:14 UTC
Fixed in version 4.0.3.208 (cycle6)

Author: Brendan Zagaeski
Commit: 6b18bbb071b9a64874d77eb5dd6b22414b599ff9 (xamarin/XamarinVS)
Comment 9 Saurabh 2016-05-05 05:18:03 UTC
I am also able to reproduce this Issue with Cycle 7 build. this is the screencast for the same: http://www.screencast.com/t/5G88PrKolyvl

I have checked the same Issue with C6SR4 build. Now this is working fine. After clicking on "Xamarin for Visual Studio Update Available", Xamarin for Visual Studio Updates window appears. This is the screencast for the same: http://www.screencast.com/t/nd9sVITXCc

Microsoft Visual Studio Ultimate 2013
Version 12.0.21005.1 REL
Microsoft .NET Framework
Version 4.6.01055

Installed Version: Ultimate

Architecture and Modeling Tools   06181-004-0452003-02593
Microsoft Architecture and Modeling Tools
    
UML® and Unified Modeling Language™ are trademarks or registered trademarks of the Object Management Group, Inc. in the United States and other countries.

LightSwitch for Visual Studio 2013   06181-004-0452003-02593
Microsoft LightSwitch for Visual Studio 2013

Microsoft Office Developer Tools for Visual Studio 2013 ENU   06181-004-0452003-02593
Microsoft Office Developer Tools for Visual Studio 2013 ENU

Team Explorer for Visual Studio 2013   06181-004-0452003-02593
Microsoft Team Explorer for Visual Studio 2013

Visual Basic 2013   06181-004-0452003-02593
Microsoft Visual Basic 2013

Visual C# 2013   06181-004-0452003-02593
Microsoft Visual C# 2013

Visual C++ 2013   06181-004-0452003-02593
Microsoft Visual C++ 2013

Visual F# 2013   06181-004-0452003-02593
Microsoft Visual F# 2013

Visual Studio 2013 Code Analysis Spell Checker   06181-004-0452003-02593
Microsoft® Visual Studio® 2013 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

ASP.NET Web Frameworks and Tools 2012.2   4.1.21001.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.0.11001.0
For additional information, visit http://www.asp.net/

Common Azure Tools   1.0
Provides common services for use by Azure Mobile Services and Windows Azure Tools.

Microsoft Web Developer Tools 2013   2.0.40926.0
Microsoft Web Developer Tools contains the following components:
Support for creating and opening ASP.NET web projects
Browser Link: A communication channel between Visual Studio and browsers
Editor extensions for HTML, CSS, and JavaScript
Page Inspector: Inspection tool for ASP.NET web projects
Scaffolding: A framework for building and running code generators
Server Explorer extensions for Windows Azure Web Sites
Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Windows Azure

NuGet Package Manager   2.8.60723.765
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

Windows Azure Mobile Services Tools   1.0
Windows Azure Mobile Services Tools

Workflow Manager Tools 1.0   1.0
This package contains the necessary Visual Studio integration components for Workflow Manager.

Xamarin   4.0.4.0 (6d27f27)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   6.0.3.7 (98d5001)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS   9.6.2.1 (03ec43b)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 12 Mohit Kheterpal 2016-06-23 18:39:40 UTC
I have checked this issue with C7 build mentioned in comment 11 and observed that this issue has been fixed as shown in screencast : http://screencast.com/t/7GiS9W5z

Using build Xamarin.VisualStudio_4.1.0.548.msi

Thanks
Comment 13 Mark 2016-08-30 00:29:23 UTC
This happening again today with VS 2015 Update 3.

Have to go Tools > Xamarin > Other > Check now.. to apply update as clicking toast notification or taskbar icon about new update does nothing.
Comment 14 Brendan Zagaeski (Xamarin Team, assistant) 2016-08-30 01:56:14 UTC
Due to a little hiccup in the way the fix was committed, there were a couple versions after 4.0.3.208 where this precise issue resurfaced.  I have tested with the current Stable version 4.1.2.18 as well as the current beta version 4.2.0.584, and this particular issue works correctly for me in both of those versions.  If you are seeing an incorrect behavior in one of those latest versions, please file a new bug report.  Be sure to describe your environment and include your logs files.  See https://kb.xamarin.com/customer/en/portal/articles/1910343 for additional details.  Thanks in advance!