Bug 38638 - Getting build error "Error initializing task XmlPeek: Not registered task XmlPeek".
Summary: Getting build error "Error initializing task XmlPeek: Not registered task Xml...
Status: VERIFIED FIXED
Alias: None
Product: Installers
Classification: Mono
Component: General (show other bugs)
Version: 4.3.0
Hardware: PC Mac OS
: High normal
Target Milestone: 4.3.2 (C7)
Assignee: dean.ellis
URL:
Depends on: 36183
Blocks:
  Show dependency tree
 
Reported: 2016-02-10 16:45 UTC by Abhishek
Modified: 2016-03-02 13:49 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 dean.ellis 2016-02-10 17:17:56 UTC
Which version of mono are you running?
Comment 2 Abhishek 2016-02-10 17:20:44 UTC
@Dean I am using mono from C7 preview branch
MonoFramework-MDK-4.3.2.421.macos10.xamarin.universal_5905ff2618cf20cc44853b43d063dbd9c7e60d22
Comment 3 dean.ellis 2016-02-10 17:25:10 UTC
In which case this is a mono bug, Android has no control of what is available in Xbuild.
Comment 4 Rodrigo Kumpera 2016-02-10 22:34:32 UTC
This is a problem with the original implementation of XmlPeek.
Comment 5 dean.ellis 2016-02-11 10:18:26 UTC
A PR has been submitted for this mono/pull/2598
Comment 6 dean.ellis 2016-02-12 11:23:41 UTC
Fixed in mono/master/96cd1c9e
Comment 7 Peter Collins 2016-02-18 21:51:20 UTC
@Dean I'm still able to reproduce an issue with XML peek, looks like an NRE of sorts. The mono on my Mac is - Mono 4.3.2 (mono-4.3.2-branch/905088b

https://gist.github.com/XamarinQA/3eba1be8a2d62109e3ea
Comment 8 dean.ellis 2016-03-01 13:54:39 UTC
@Peter this have been cherry-picked to 4.4.0 

mono/mono-4.4.0-branch/5b47a318

Looking at the log you posted that version does not have the fix in it as its still referencing LogErrorFromResource
Comment 9 Abhishek 2016-03-02 13:49:30 UTC
I have checked this issue with the latest C7 mono and master build:
MonoFramework-MDK-4.4.0.24.macos10.xamarin.universal_7770133d8b2705a272e0ccdb15d81fe04b801cfe
mono-android-6.1.99-20_1009372b569bd1d0497eaa5526155b6bdffde9fd
XamarinStudio-6.1.0.134_f70cf80df106201cb47315711a35fcb28383e747.

Now I am successfully able to build the sample application. Here is the screencast:
http://www.screencast.com/t/JjFP9KzOUKsx

Build Output: https://gist.github.com/Abhishekk360/c70dd71cb048c5608772.

Hence closing this issue.
Thanks.