Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android (show other bugs)
Version: 4.3.0 (C9)
Hardware: PC Windows
: Normal normal
Target Milestone: 4.2.1 (C8SR1)
Assignee: Jason Imison
URL:
: 42970 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-09 10:32 UTC by Simon Friis Vindum
Modified: 2016-08-09 13:26 UTC (History)
11 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Simon Friis Vindum 2016-02-09 10:32:22 UTC
Steps to reproduce:

1/ Create a new project in Visual Studio
2/ Select Visual F#, Androd and "Blank App (Android)".
3/ Create the project

The solution explorer now shows "(load failed)" next to the project name. Hovering the mouse over the error shows "The project requires user input. Reload the project for more information". I've tried reloading the project with no effect.

I am using Visual Studio version 4.6.01038 with Visual F# 2015 and with Xamarin for Visual Studio 4.0.1.96 and Xamarin.Android 6.0.1.10.

Creating a blank Android app using C# works just fine.
Comment 1 Simon Friis Vindum 2016-02-11 18:02:57 UTC
I can, without problems, build and deploy the F# Xamarin.Forms samples found here: https://github.com/xamarin/xamarin-forms-book-preview-2

This makes me think that this bug has something to do with the code generated by the blank app template.

Is there any other way that I can get started on an Android project using F#?
Comment 2 stepan 2016-02-14 22:24:18 UTC
Blank App (Android) is not a Xamarin.Forms project. It is instead similar to *.Droid projects from the that github repo and they also cannot be loaded. Therefore it seems that this issue is not related to project generation.
Comment 3 James Moore 2016-05-05 18:36:28 UTC
I don't think it has anything to do with the templates, it's that Xamarin is trying to use an old version of F#.

http://stackoverflow.com/questions/36349718/unable-to-create-f-android-project-visual-studio-2015-xamarin-community

Workaround from that stackoverflow post is:

You can install F# 3.0 SDK from here: http://go.microsoft.com/fwlink/?LinkId=261286
Comment 4 Miguel de Icaza [MSFT] 2016-08-03 15:06:08 UTC
*** Bug 42970 has been marked as a duplicate of this bug. ***
Comment 5 Jason Imison 2016-08-04 10:55:02 UTC
PR here - https://github.com/xamarin/xamarin-android/pull/141