Bug 38525 - kill -QUIT produces a very broken stacktrace
Summary: kill -QUIT produces a very broken stacktrace
Status: VERIFIED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: High major
Target Milestone: (C7)
Assignee: Zoltan Varga
URL:
Depends on:
Blocks: 37968
  Show dependency tree
 
Reported: 2016-02-07 12:01 UTC by Alan McGovern
Modified: 2016-06-02 13:19 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Alan McGovern 2016-02-07 12:01:22 UTC
Neither mono's `kill -QUIT $PID` method of writing stacktraces nor gdb's `t a a bt` showed that managed code was running in the main thread. Only LLDB did.

Can we at least fix `kill -QUIT` because we rely on that *a lot* to figure out what our threads are doing. Here is an example threaddump from mono, gdb and lldb where only lldb shows managed code in the main thread.

https://gist.github.com/alanmcgovern/9eee935fc26efbe3655e
Comment 1 Zoltan Varga 2016-02-07 20:47:58 UTC
This is probably caused by the monitor changes, we directly call the monitor_enter () etc. c functions without a wrapper so we can't produce an async stacktrace if they block.
Comment 2 Zoltan Varga 2016-02-11 02:30:37 UTC
Fixed in mono master c5512c0d3e2b102ed16158ce8c599c8203ccd510 and the mono-4.3.2-branch 9f44a62acf718d91320420c1c77e855a63f3c3f9.
Comment 3 Shruti 2016-06-02 11:25:40 UTC
@Alan, @Zoltan : It would be great if you let us know that what and how to reproduce this issue. This issue must be reproduced at our end before verifying it. 

Looking for your help!

Thanks!!
Comment 4 Zoltan Varga 2016-06-02 12:36:10 UTC
Its not a product problem, it doesn't need to be verified.
Comment 5 Shruti 2016-06-02 13:19:48 UTC
Thanks @Zoltan for the information. I am closing this issue as per comment(4).

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 38525 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: