Bug 38461 - PropertyInfo.CanWrite can return different value on OSX than Windows
Summary: PropertyInfo.CanWrite can return different value on OSX than Windows
Status: RESOLVED DUPLICATE of bug 32609
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll (show other bugs)
Version: XI 9.4 (iOS 9.2)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-02-04 17:13 UTC by Alexandre Emond
Modified: 2016-02-04 17:25 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Alexandre Emond 2016-02-04 17:13:48 UTC
If we are running the same code on a Windows console app (with Visual Studio) VS Mac Console app or iOS App (with Xamarin Studio), we do not get the same value.  Sample code :

    class Program
    {
        static void Main(string[] args)
        {
            Console.WriteLine(typeof(MyClass).GetProperty("MyProperty").CanWrite);          // OK    : True (Windows), True (Xamarin Studio Console Project)
            Console.WriteLine(typeof(TestEntity).GetProperty("MyProperty").CanWrite);       // ERROR : False (Windows), True (Xamarin Studio Console Project)
            Console.ReadKey();
        }
    }

    public class MyClass
    {
        public string MyProperty
        {
            get; private set;
        }
    }

    public class TestEntity : MyClass { }

In fact, it's the same issue as : https://bugzilla.xamarin.com/show_bug.cgi?id=32609 which was closed on 2015-07-31.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2016-02-04 17:25:12 UTC
The current stable version of Xamarin.iOS (9.4) is based on a Mono version which is from before the fix for bug #32609.

The next major release will include the fix.

*** This bug has been marked as a duplicate of bug 32609 ***

Note You need to log in before you can comment on or make changes to this bug.