Bug 38433 - [XVS C6SR1] The Info.plist editor does not display any tabs if it is opened with a window width below a certain minimum
Summary: [XVS C6SR1] The Info.plist editor does not display any tabs if it is opened w...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 4.0.0 (C6)
Hardware: PC Windows
: --- major
Target Milestone: 4.0.1 (C6SR1)
Assignee: Bugzilla
URL:
: 38418 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-02-04 09:11 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2016-02-26 22:11 UTC (History)
6 users (show)

Tags: BZRC6SR1S1_C6S3
Is this bug a regression?: ---
Last known good build:


Attachments
Screencast of the "bad" behavior in 4.0.1.93 (710.92 KB, application/x-shockwave-flash)
2016-02-04 09:11 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details
Screencast of the "good" behavior in 4.0.0.1717 (1.22 MB, application/x-shockwave-flash)
2016-02-04 09:11 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2016-02-04 09:11:31 UTC
Created attachment 14887 [details]
Screencast of the "bad" behavior in 4.0.1.93

[XVS C6SR1] The Info.plist editor does not display any tabs if it is opened with a window width below a certain minimum


This is an "intensification" of Bug 38428. Bug 38428 itself is not a regression. But there is a new symptom in Cycle 6 – Service Release 1 where the tabs will stay hidden even when you close and reopen the PList editor.




## Workaround

Drag the `Info.plist` editor tab out into a floating window (Window -> Float), and then maximize that window.


(This will hopefully allow the editor tabs to reappear. I tried some brief tests with different screen resolutions, and in those test the workaround was effective down to 1280x720, but it was no longer effective at 1024x768.)




## Regression status

BAD:  XamarinVS 4.0.1.93   (c7ebc0f) + Visual Studio 2013 Update 5
BAD:  XamarinVS 4.0.1.93   (c7ebc0f) + Visual Studio 2015 Update 1

GOOD: XamarinVS 4.0.0.1717 (1390b70) + Visual Studio 2013 Update 5
GOOD: XamarinVS 4.0.0.1717 (1390b70) + Visual Studio 2015 Update 1



(Note: the VS 2013 Windows test environment and VS 2015 Windows test environment are 2 separate installations of Windows.)




## Steps to replicate

1. Open Visual Studio and maximize the window.

2. Open an `Info.plist` file from an iOS project in the PList editor.

3. Resize the Solution Explorer window (or any window that's docked beside the PList editor window) so that it takes up most of the width of the whole outer VS window. This should trigger Bug 38428 so that the PList editor tabs disappear.

4. Once you have triggered Bug 38428, close the PList editor window, and then reopen it.




## Results

On XamarinVS 4.0.1.93, the PList editor tabs remain hidden.




## Expected results

On XamarinVS 4.0.0.1717, the PList editor tabs are shown.

(If you resize the window slightly at this point, you will again hit Bug 38428 and the tabs will disappear, but the important thing is that the tabs _were_ visible when the window first opened.)
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2016-02-04 09:11:57 UTC
Created attachment 14888 [details]
Screencast of the "good" behavior in 4.0.0.1717
Comment 4 Brendan Zagaeski (Xamarin Team, assistant) 2016-02-04 09:16:32 UTC
For better searchability of this bug, the titles of the tabs that get hidden are:

"iPhone Icons", "Entitlements", "Map Integration", and "Background Modes"
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2016-02-04 09:17:55 UTC
*** Bug 38418 has been marked as a duplicate of this bug. ***
Comment 9 Brendan Zagaeski (Xamarin Team, assistant) 2016-02-06 04:56:43 UTC
## Status update

The candidate fix for this issue has now been published as a hotfix to the Stable updater channel in XamarinVS 4.0.1.96.
Comment 10 xamarin-release-manager 2016-02-26 22:11:45 UTC
Fixed in version 4.0.1.127 (cycle6)

Author: Emanuel
Commit: 640161dcdc9dfdf4c8690f8b684e3a37cd1e59ed (xamarin/XamarinVS)