Bug 38295 - System.IO.Compression.ZipArchiveEntry - issue with reopening entries
Summary: System.IO.Compression.ZipArchiveEntry - issue with reopening entries
Status: RESOLVED DUPLICATE of bug 33553
Alias: None
Product: Class Libraries
Classification: Mono
Component: General (show other bugs)
Version: master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: João Matos
URL:
Depends on:
Blocks:
 
Reported: 2016-02-02 12:43 UTC by RichardW
Modified: 2016-02-22 16:32 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description RichardW 2016-02-02 12:43:05 UTC
I've been trying to use the latest version of the Open XML SDK with Mono 4.3.3 (built off the master branch), and as described at https://github.com/OfficeDev/Open-XML-SDK/issues/74 I'm running into a problem that looks to be a Mono issue.

I think it essentially reduces down to the situation that the code

using (ZipArchive archive = new ZipArchive(input, ZipArchiveMode.Update))
     {
         ZipArchiveEntry selectorEntry = archive.GetEntry("readme.txt");
         using (Stream temp = selectorEntry.Open())
          {
              Console.WriteLine("Open1");
          }

         using (Stream temp = selectorEntry.Open())
          {
               Console.WriteLine("Open2");
          }
     }

Works on MS .NET4.5 but on Mono throws an exception on the second open, because it thinks the stream is already open although it has actually been closed.

I'm wondering, should the

 if (openStream != null && Archive.Mode == ZipArchiveMode.Update)
                throw new IOException("The entry is already currently open for writing.");

In ZipArchiveEntry.Open() be a bit more clever, and do something like check if the stream has been disposed, even though it's non-null? Not sure if there are any other side effects of that though.
Comment 1 João Matos 2016-02-22 16:32:51 UTC
Hi, thanks for reporting this bug to us.

Coincidentally, I've already fixed it as part of https://bugzilla.xamarin.com/show_bug.cgi?id=33553.

*** This bug has been marked as a duplicate of bug 33553 ***

Note You need to log in before you can comment on or make changes to this bug.