Bug 38284 - when creating a map in iOS, if the map is not visible when the page is created the zoom level is off
Summary: when creating a map in iOS, if the map is not visible when the page is create...
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2016-02-01 22:12 UTC by christine.blanda
Modified: 2017-02-01 16:51 UTC (History)
7 users (show)

See Also:
Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
sample code - MapTest (62.17 KB, application/zip)
2016-02-01 22:18 UTC, christine.blanda
Details
iOS with 2.3.1.51-pre1 (465.01 KB, image/png)
2016-06-21 18:33 UTC, christine.blanda
Details
android with 2.3.1.51-pre1 (357.60 KB, image/png)
2016-06-21 18:33 UTC, christine.blanda
Details

Description christine.blanda 2016-02-01 22:12:27 UTC
Run the attached sample code, which creates 2 identical maps, one visible and one not.  After the page loads, click the button to view the second map.  Note that the zoom level on the second is not the same as that of the first, it is zoomed out.
Comment 1 christine.blanda 2016-02-01 22:18:27 UTC
Created attachment 14840 [details]
sample code - MapTest
Comment 2 Lynn Koehler 2016-04-28 02:55:03 UTC
Updated Xamarin.Forms and Xamarin.Forms.Maps to 2.2 and the problem persists.
Comment 3 Rui Marinho 2016-06-16 17:09:40 UTC
Should be fixed in 2.3.1-pre1
Comment 4 christine.blanda 2016-06-21 18:31:36 UTC
Just tested with Forms and Forms.Maps 2.3.1.51-pre1 and it is still an issue in iOS and also for android Android.  I'll upload screanshots.
Comment 5 christine.blanda 2016-06-21 18:33:08 UTC
Created attachment 16424 [details]
iOS with 2.3.1.51-pre1

Screenshot running on iOS.  The only difference between the maps is the bottom one was not visible initially.  They should be zoomed the same but aren't
Comment 6 christine.blanda 2016-06-21 18:33:50 UTC
Created attachment 16425 [details]
android with 2.3.1.51-pre1

Screenshot running on Android.  The only difference between the maps is the bottom one was not visible initially.  They should be zoomed the same but aren't
Comment 7 Parmendra Kumar 2016-06-29 18:26:17 UTC
I have checked this issue with Xamarin.Forms 2.3.1.110-pre1 and I am still facing same issue as mentioned in bug description.

Screencast: http://www.screencast.com/t/wEpseL2lqK

Thanks.
Comment 8 adrianknight89 2016-11-18 22:33:08 UTC
The problem is not with the second map. It's with the first one. When layout changes, the first one is not moving its camera to the correct region.

See https://github.com/xamarin/Xamarin.Forms/pull/548
Comment 9 Rui Marinho 2017-01-03 11:40:52 UTC
Should be fixed in 2.3.4-pre2
Comment 10 Parmendra Kumar 2017-02-01 16:51:35 UTC
I have checked this issue with Xamarin.Forms 2.3.4.184-pre1 and observed that this issue has been fixed.

Hence marked this issue as Verified Fixed.


Thanks.

Note You need to log in before you can comment on or make changes to this bug.