This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 38204 - [iOS] Picker Fires SelectedIndexChanged Early
Summary: [iOS] Picker Fires SelectedIndexChanged Early
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-01-29 20:08 UTC by Jimmy [MSFT]
Modified: 2017-01-30 18:32 UTC (History)
6 users (show)

See Also:
Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
repro solution (48.69 KB, application/zip)
2016-01-29 20:08 UTC, Jimmy [MSFT]
Details

Description Jimmy [MSFT] 2016-01-29 20:08:58 UTC
Created attachment 14804 [details]
repro solution

### Overview
The Picker on iOS fires off the SelectedIndexChanged event as the user scrolls through the items in the control, not after an item is actually selected.


### Steps to Reproduce
1. Run the attached iOS project
2. Open the Picker and scroll through the items


### Expected Results
Selecting an item from the Picker will update the Label beneath the Picker.


### Actual Results
The Label is updated as the items in the Picker are scrolled through.


### Testing Info
I was able to reproduce this on Forms 2.0.1 and 2.1-pre3. However, this does not occur on the default Forms 1.3.5 from the new project template. So indicates that this is a regression introduced since then.
Comment 1 Jimmy [MSFT] 2016-01-29 23:03:51 UTC
Just to clarify, the issue doesn't happen when the user is actually scrolling, but when they highlight the item in the Picker and don't select "Done". 

So if one iterates through the items one by one, the label in the sample project changes each time a new item is highlighted.
Comment 2 adrianknight89 2016-10-20 21:31:58 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/478
Comment 3 Rui Marinho 2016-12-20 20:09:33 UTC
https://github.com/xamarin/Xamarin.Forms/pull/540
Comment 4 Rui Marinho 2017-01-04 13:16:20 UTC
Should be fixed in 2.3.4-pre2
Comment 5 Parmendra Kumar 2017-01-30 18:32:42 UTC
I have checked this issue with Xamarin.Forms 2.3.4.184-pre1 and this issue is not reproducible with latest forms version I am getting same behaviour with Android and iOS. Hence marked this issue as Verified Fixed.
If you still facing same issue please feel free to reopen this issue.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.