Bug 38128 - After navigating to another page and then returning, secondary toolbar item drawn in middle of page
Summary: After navigating to another page and then returning, secondary toolbar item d...
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 2.0.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2016-01-28 16:36 UTC by John Hardman
Modified: 2017-06-19 21:15 UTC (History)
4 users (show)

Tags: iOS ListView Secondary toolbar navigation
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description John Hardman 2016-01-28 16:36:20 UTC
On iOS, on a ContentPage with a ListView and one secondary menu item, after navigating to another page using a Context Action attached to one of the items in the ListView, and then hitting Back to return to the original page, the secondary menu item is drawn in the middle of the page instead of near the top.
Comment 1 John Hardman 2016-01-28 16:38:26 UTC
That should have said "secondary toolbar item"
Comment 2 John Hardman 2016-01-28 16:49:33 UTC
Note that if a primary toolbar item is used, this works fine. The problem only occurs with a secondary toolbar item.
Comment 3 Rui Marinho 2016-12-20 20:00:01 UTC
Thank you for taking the time to submit the bug. We tried to reproduce the issue you reported but were unable given the description. If you could please attach a reproduction to the bug by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue, we would very much appreciate it.  


For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d  

Warm regards, 

Xamarin Forms Team
Comment 4 Chris King 2017-06-19 17:21:26 UTC
Assigned to you as you were last to request additional info.
Comment 5 Samantha Houts [MSFT] 2017-06-19 21:15:28 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!