Bug 38108 - Adding .Net 2.0 Web Service reference puts incorrect paths in csproj file for .disco / .wsdl files
Summary: Adding .Net 2.0 Web Service reference puts incorrect paths in csproj file for...
Status: RESOLVED DUPLICATE of bug 36116
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Add-ins (show other bugs)
Version: 6.0.0 (C7)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2016-01-27 20:28 UTC by David Hathaway
Modified: 2016-01-28 09:47 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 36116

Description David Hathaway 2016-01-27 20:28:14 UTC
Steps to reproduce:

1. Create a new Single View iOS application in Xamarin Studio
2. Right click on project, and click "Add > Add Web Reference"
3. Point to an asmx service (using the pre-filled Temp Convert web service is fine)
4. Select ".Net 2.0 Web Services" for the Framework, leave everything else as is
5. Click "OK"

The project will be updated, and there are references to a .disco and .wsdl file, but the relative path in the .csproj file is incorrect.  User has to manually re-add those files (either by editing the csproj file, or by removing/adding the files from the project in the IDE).

Here is the actual folder path (when using the Temp Convert web service)

Web References\www.3schools.com\TempConvert.disco
Web References\www.3schools.com\TempConvert.wsdl

However, the csproj file has references to:

<None Include="..\..\..\..\..\..\..\..\TempConvert.disco" />
<None Include="..\..\..\..\..\..\..\..\TempConvert.wsdl" />
Comment 1 Matt Ward 2016-01-28 09:47:31 UTC
This is due to a bug #38108 in Mono 4.2 where it puts in the wrong path into the Reference.map generated when adding the web reference. The filename in the reference.map's file starts with a / so Xamarin Studio resolves to that file and ends up including all those ..\..\ since it believes the file is all the way back in the root directory.

The current workaround is to downgrade to Mono 4.0 where this problem does not occur.

*** This bug has been marked as a duplicate of bug 36116 ***