Bug 38023 - Class library do not rebuild
Summary: Class library do not rebuild
Status: RESOLVED DUPLICATE of bug 37331
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries (show other bugs)
Version: 6.0.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2016-01-26 08:45 UTC by cheansiong
Modified: 2016-02-17 10:24 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Demo project so simulate the problem. (30.96 KB, application/x-zip-compressed)
2016-01-26 08:45 UTC, cheansiong
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 37331

Description cheansiong 2016-01-26 08:45:50 UTC
Created attachment 14731 [details]
Demo project so simulate the problem.

Changes to the ClassLibrary didn't not copy to the Reference Project until a rebuild.

Steps to reproduce:
1. Make changes to the ClassLibrary, eg: Change Styles.xml color from white to black.
2. The changes does not take effect immediately for a build and require a rebuild for whole solution.

Note: Before upgrades to Xamarin 4, it works.
Comment 1 cheansiong 2016-02-17 05:39:16 UTC
Any updates?
Comment 2 dean.ellis 2016-02-17 10:24:51 UTC
This is a duplicate of #37331. It has been fixed in our master branches and will be in the next release.

*** This bug has been marked as a duplicate of bug 37331 ***