Bug 37680 - Map V2 does not work on Android 6 devices
Summary: Map V2 does not work on Android 6 devices
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 2.0.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-01-14 08:46 UTC by FieldstrikeMobile
Modified: 2016-01-18 08:38 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description FieldstrikeMobile 2016-01-14 08:46:30 UTC
Xamarin.Forms.Maps 2.0.0.6490 does not work on Android 6 devices.

You just get a grey Map box (including google logo, zoom buttons) where no mao tiles are ever loaded
Comment 1 Paul DiPietro [MSFT] 2016-01-17 02:15:55 UTC
We have had this tested on a physical 6P device and can confirm it is working as intended, and that any bugs likely have to do with the emulator or API key.
Comment 2 FieldstrikeMobile 2016-01-18 08:38:01 UTC
from here https://blog.xamarin.com/is-your-app-ready-for-android-marshmallow/

If your application is using the Xamarin.Forms Maps NuGet, you should continue to compile against API 22 until the Xamarin.Forms.Maps NuGet has official support for the latest Google Play services SDK.

So the actual problem is if you target API 23 maps doesn't work