We bind UnwindAction as a Selector, but according to https://developer.apple.com/library/ios/technotes/tn2298/_index.html : "An unwind action is an instance method with a UIStoryboardSegue as its only parameter and whose return type is IBAction."
It would be a little more C#-ish to allow developers to just pass in the function rather than a selector.
A bit tricky (API compatibility) but we should be able to provide a (non-virtual) helper method that calls the selector.
From the description you mentioned it looks like the signature should be:
> Func<UIStoryboardSegue, IBAction>
but since `IBAction` is kind of `void` for IB then would be:
^ needs to be tested