Bug 37654 - Call tree not sorting children
Summary: Call tree not sorting children
Status: VERIFIED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: General (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: (C8)
Assignee: Rodrigo Moya
URL:
Depends on:
Blocks:
 
Reported: 2016-01-13 17:07 UTC by Rodrigo Moya
Modified: 2016-02-01 18:48 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Rodrigo Moya 2016-01-13 17:07:39 UTC
From Marius:
"On Mac, when I profile something and use Running Time as a sorting column, only the root nodes get sorted.

Expanding a node does not give children sorted by the selected sorting model."

This is due to how we do the storage/sorting of the call tree view, so indeed a bug.
Comment 1 xamarin-release-manager 2016-01-20 16:38:02 UTC
Fixed in version 0.30.0.74 (master)

Author: Rodrigo Moya
Commit: e23c4a7229f850c519c3fd74fb12eecbc19ab198 (xamarin/profiler)
Comment 2 asimk 2016-02-01 18:48:32 UTC
I have checked this issue with latest profiler build i.e. profiler-mac-0.30.0-108 and observed that this issue has been fixed. Here is the screencast for the same.

Screencast: http://www.screencast.com/t/jkyzmzMFyh6