This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 37648 - Opening Workspace (.mdw) - Unknown file format (solution name not displayed)
Summary: Opening Workspace (.mdw) - Unknown file format (solution name not displayed)
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model (show other bugs)
Version: 5.10 (C6SR3)
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: (C8)
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2016-01-13 16:11 UTC by RobertN
Modified: 2016-07-14 13:58 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Error dialog without the solution name shown (23.89 KB, image/png)
2016-01-13 16:11 UTC, RobertN
Details

Description RobertN 2016-01-13 16:11:02 UTC
Created attachment 14570 [details]
Error dialog without the solution name shown

Opening a workspace that has a missing solution from within a *non-existent* directory, the Error Dialog does not show the actual solution that is the cause. 

   "Could not load solution item: xxxxxxx: Unknown file format:"
   "Load operation failed: Unknown file format:"

Note: If the directory does exist, but the solution does not, then the missing solution name is reported in the Error Dialog and thus you know which `.sln` is causing the issue.


Test `.mdw` file:

<WorkspaceItem ctype="Workspace">
  <Items>
    <Item>foobar/foobar.sln</Item>
  </Items>
</WorkspaceItem>

BTW: This error is also not logged in the `ide.log`
Comment 1 xamarin-release-manager 2016-07-14 10:53:26 UTC
Fixed in version 6.2.0.175 (master)

Author: Lluis Sanchez
Commit: bbb6c18a580a5692f21721a44de890592f58fc57 (mono/monodevelop)
Comment 2 xamarin-release-manager 2016-07-14 10:53:50 UTC
Fixed in version 6.1.0.5231 (cycle8)

Author: Lluis Sanchez
Commit: feb2598d2897776c734c85f691025918ff63da1a (mono/monodevelop)
Comment 3 Naqeeb 2016-07-14 13:58:05 UTC
I have checked this issue with Cycle8 XamarinStudio-6.1.0.5232_d041eabe45172481655db70a5357be2ae53f8192  and observed that it is working fine. I am getting solution name in error popup. Here is the screencast for the same: http://www.screencast.com/t/K25nyERvD

Hence closing this issue.

Environment info: https://gist.github.com/NaqeebAnsari/35983cfb0d826d5547dd7fc19ee31863

Note You need to log in before you can comment on or make changes to this bug.